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Preface
About This Manual
This manual is intended for operators. If it’s your first time to use Bodor CNC system, we suggest that
you read through this manual. If not, you can search for the information you need through table of
contents.
With 4 chapters, this manual can be divided into 5 parts as follows.
1)

2)

3)

4)
5)

Part 1: The preface, introducing the precautions about transportation and storage, installation,
wiring, debugging, usage and so on. You need to read them carefully before operating to ensure
safe operations.
Part 2: The quick start part. Please refer to chapter 1. This chapter gives an introduction to
functional characteristics, installation of CNC system interfaces and operation flows of BodorPro
V2.0.
Part 3: The function part. Please refer to chapter 2. This chapter gives an introduction to the
interfaces, operations, parameters and settings related to each function. You will gain more
knowledge of the operation units and operation commands.
Part 4: The machining debugging part. Please refer to chapter 3. This chapter gives an introduction
to hardware, including parameter setting of the driver and the machine tool.
Part 5: The appendix. Please refer to chapter 4. This chapter includes an introduction about wiring
of the terminal board and the wireless control handle, the parameter list, the hot key list and the
software license agreement.

Contact Us
You can contact us by the following info for technical support and pre-sales / after-sales service:
Company Name:

Jinan Bodor CNC Machine Co.,Ltd.

Headquarters Address:

No.1299, Xinluo Ave Hi-tech Zone Jinan, Shandong, China

Tel:

400-991-7771

International:

+86-0531-88690051

Website:

www.bodor.com

Revision History
You can refer to the following table for the revision records of each edition.
Date

Edition

2017.06

R1

Revision
Released for the first time.
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Precautions
Precautions can be divided into caution and warning according to the degree of possible loss or injury in
case of negligence or omission of precautions stipulated in this manual.

: general info, mainly for informing, such as supplementary instructions and
conditions to enable a function. In case of negligence or omission of this kind of precautions, you may
not activate a function. Note that in some circumstances, negligence or omission of this kind of
precautions could cause physical injury or machine damage.

: warning info requiring special attention. In case of negligence or omission of this
kind of precautions, you may suffer physical injury, or even death, machine damage or other losses.

1)

Precautions Related to Storage and Transportation



The products should be transported properly in terms of the weight;



An excess of specified quantity of stacking products is prohibited;



Climbing, standing or placing heavy loads on the products is prohibited;



Dragging or carrying the products via cables or devices connected to them is prohibited;



Protect products from moisture when saving and transporting them.

2)

Precautions Related to Installation



Only when this equipment installed in the qualified electricity cabinet can it be used. The
construction of the cabinet must reach IP54 grade of protection;



Paste sealing strips on the joint of the cabinet to seal all the cracks;



Cable entry should be sealed while easy-to-open on the spot;



A fan or heat exchanger should be adopted for the heat dissipation and air convection of the
cabinet;



If a fan is adopted, air strainer is a must in air inlet or air outlet;



Dust or cutting fluids may have access to the CNC device via the tiny cracks and tuyere.
Therefore it is necessary to pay attention to the surroundings and air flow direction of the air
vent to make sure that the outflow gas is towards pollution source;



100 mm space should be preserved between the back of the CNC device and the cabinet wall
for plugging cable connected with the device and the ventilation & heat dissipation in the
cabinet;



Space between this device and other equipment should also be preserved according to the
requirements;
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The product should be installed firmly and without vibration. During installing, casting,
knocking, striking, or loading on the product is forbidden;



To reduce electromagnetic interference, power-supply components used should be above AC
or DC 50V and the space between cable and CNC device should be preserved above 100mm;



It will be better if CNC device is installed at a position facilitating debugging and maintenance.

3)

Precautions Related to Wiring



Only qualified people are allowed to participate in the wiring and checking;



The CNC device should be grounded reliably and grounding resistance should be less than 4
ohm. Neutral line is absolutely not allowed to replace earth wire. Otherwise, it may result in
malfunction of the device due to the interference;



Wiring should be firm and steady, or maloperation may occur;



Voltage values and positive & negative polarity of any connection plug should be in accordance
with specifications set forth in the manual, or it may result in breakdowns such as short circuit
and permanent damage to the device;



To guard against electric shock or CNC device damage, fingers should keep dry before
plugging or touching switch;



The connecting wire should not be damaged and squeezed, or the leakage or short circuit may
occur;



It is prohibited to plug or open the chassis of CNC device when power on.

4)

Precautions Related to Running & Debugging



Parameters setting should be checked before running, since wrong setting may lead to
accidental movements;



Modification to parameters should be within the allowable range, or such breakdowns as
unsteady running and machine damage will occur.

5)

Precautions in Use



Before power-on, please make sure that the switch is on blackout to avoid occasional start-up;



Please check the electromagnetic compatibility during electrical design in order to avoid or
reduce electromagnetic interference to the CNC device. A low pass filter should be employed
to reduce electromagnetic interference if there are other electrical devices nearby;



It is not allowed to frequently power on and power off. It is recommended to power up the
machine again at least one (1) minute later after power failure or blackout.
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1)

Precautions Related to Product and Manual



Matters related to restrictions and functions available stipulated in the manuals issued by the
machine manufacturer are prior to those in this manual;



This manual assumes all the optional functions are available, which you must confirm through
manuals issued by the machine manufacturer;



Please refer to manuals issued by the machine manufacturer for the instructions of machine
tools;



Functions, and software interfaces vary with the system and the version of software. Before
using the system, you must confirm the specifications.

2)

Precautions When Opening the Package



Please make sure that the products are what you have ordered;



Check if the products are damaged in transit;



Check if the components and accessories are damaged or missing in terms of the detailed list;



Please contact us if product discrepancy, accessory missing or transit damage occurs.
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1 Quick Start
This chapter gives a summary of functional characteristics, system installation, software interface and
basic operational procedures. If you use the system for the first time, it is recommended to go over this
chapter from which you can obtain a primary knowledge of the system and get familiar with operations in
real machining. If you have known the system well, you can skip this chapter.

1.1 Functional Characteristics

















Supporting 2D and 3D cutting, mainly 2D cutting;
Supporting various file formats, including G-code file,IGS file, NC file, DXF file, PLT file, ENG
file, etc.;
Supporting preprocessing imported objects;
Providing kinds of pulse modulation signals to mate with different laser machine and to adjust
duty ratio according to cutting speed;
Supporting layer function and technics such as cutting with film, corner loop, cutting at fixed
height;
Supporting various piercing methods such as direct pierce, incremental pierce, segmented
pierce, three segment pierce and pre-pierce; besides, you can set laser power, frequency, gas
type and pressure separately in piercing and cutting;
Supporting library function, and allowing all the technical parameters to be saved for next use
on the same material;
Supporting frog leap function, which controls the motion between objects by parabolic type
instead of the classic rectangle type;
Supporting speed power adjustment and adopting graphic method to set the power of different
speeds;
Supporting follow-up function;
Supporting function of calibrating metal and nonmetal;
Supporting wireless remote control handle whose direct-vision transmission free of barrier
reaches 60 m;
Supporting scan cutting, including line scan, arc scan and scan on LED text;
Supporting tube cutting function;
This system supports Vertical Screen configuration and Tube configuration. Unless otherwise
specified, screenshots, parameters, ports and other information mentioned in this manual are
default in vertical screen configuration.
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1.2 Installation of CNC System
1.2.1
CPU:

basic frequency 1G or above

Memory:

above 1G

Hard disk:

above 20G, with D disk available

Display adapter:

900*1440 at least

Display:

above VGA 19"

Main board extension slot:

1 or more PCI/PCIE slot

1.2.2





Configuration for CNC System

BodorPro software;
One PM85A servo control card;
Two DB9M/F communication cables;
I/O board: Lambda 5S controller, EX30A5 terminal board, and EX31A1 terminal board.

1.2.3


Requirements for Computer Configuration

Set up Control Card

Control card setup steps
1) Insert the software Usb flash driver of computer, and then double click “setup. exe” for
installation of the software until finished;
2) Power off the computer, then open the computer chassis, and then insert the control card into a
PCI/PCIE slot and fasten the screw of rail block, and then lid the computer case;
3) Power on the computer. The computer will find the new hardware-device and install its driver
automatically. Please refer to 1.2.4 for how to update device driver.
4) Open BodorPro. If it runs normally, installation is over. If not, please check whether the control
card is well inserted and the gold finger is clean.

 Control card detection
Take origin switch port examination as an example to introduce the method to examine input ports.
If the origin switch is normally closed(open), LEDs for X0 and Y0 are normally on. Trigger the origin
switch through artificial imitation:
 For travel switch, press the switch;
 For photoelectrical switch, obstruct the light;
 For metal proximity switch, approach it with a metal block.
If the corresponding LEDs turn out(on), the origin signals have been sent to the terminal board.
Otherwise, the signals have not been sent to the terminal board.
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1.2.4

Set up BodorPro

If it is the first time you install BodorPro, please install the basic environment package as shown in Fig.
1- 1 first.

Fig. 1- 1 Basic Environment Package

The setup of BodorPro can be divided into the following steps:
1)

Install the BodorPro system Usb Flash Disk inserted into the computer. Double click Computer icon,

then double click the CD-ROM icon. Find and double click the icon

. A language selection

dialog box will pop out. If you select “选择中文界面”, the setup wizard and software interface will be
in Chinese. And if you select “ENGLISH”, the setup wizard and software interface will be in English.
Besides, you can switch interface language in the software.
2)

Select a language according to your needs. And a dialog box will pop out asking whether to update
the software. Click “Yes” to start updating.

3)

If it is your first time to install the software, the system will pop out a dialog box about installing driver
software, choose “Install the driver software anyway”.

4)

If an old version exists, the system will warn that the files in directory (C:\Program
Files\Bodor\BodorPro\)”. Click “OK”.

5)

If an old version exists, the system will then ask whether to save the configuration parameters set
before. You can select “Yes” or “No” according to your needs.

6)

Installation begins. The software will be installed under the default directory, C:\Program
Files\Bodor\BodorPro. During installation, a dialog box will pop up asking whether to put generated
files and executive files separately. “No” is recommended.

7)

A dialog box will pop up asking whether to shut down the computer. “OK” is recommended. After the
computer is restarted, setup is completed.

To uninstall BodorPro, delete the folder “BodorPro” under directory C:\Program Files\Bodor.
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1.2.5

Install Device Driver

If the BodorPro can’t open after BodorPro software and control card are installed, it indicates that auto
installation may have failed. And after excluding other causes such as loose control card, you can install
the device driver manually.

Fig. 1- 2 Read Board Information Error

Fig. 1- 3 Reinstall Software

If it is your first time to install the device driver, you should take the following steps before step 3 in Fig.
1- 4:
1) Click

button in the toolbar of “Device Manager” or right click on “Other devices” and select

“Scan for hardware changes” to update device list.
2) Right click on “Network and Computing Encryption/Decryption Controller” and select “Update
Driver Software”.
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Fig. 1- 4 Steps to Install Control Card Driver Manually
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1.3 Software Interface
1.3.1

Vertical Screen Configuration

Fig. 1- 5 User Interface
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Monitor display area: it shows monitoring screen when camera is connected.
Menu bar: it shows menus of all levels.
Tool bar: it shows common tool buttons when no objects are selected and shows setting boxes when
objects are selected.
Drawing tool bar: it includes view adjustment tools, tools for drawing (dot, line, circle, etc), object
editing tools (array, distance measurement), and technic setting tools (layer, Edge finding, instant setting,
etc).
Object editing area: it corresponds to worktable travel range, within which the objects to be machined
should be.
Report bar: it shows current object machining time and total running time of the software, current status,
current feedrate and current layer.
Warning bar: it shows error information, including titles, causes and solutions.
Status bar: it shows information of currently being edited objects, such as tips for drawing steps and
effect, result of the ongoing operations, moving distance, etc.
Machine control area: it includes machining data display area, and machining control button area and
motion control button area.


Machining data display area
Machining data display area displays the current feedrate, the current power, current follow height,
workpiece coordinates and machine coordinates as shown in Fig. 1- 6.

Fig. 1- 6 Machining Data Display Area



Machining control button area

Machining control button area is as shown in Fig. 1- 7. The operation buttons are on the left, while the
port buttons and reserved buttons are on the right. You can control machining process with the buttons.
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Fig. 1- 7 Machining control button area



Motion control button area

1.3.2

Tube Cutting Configuration

The differences between vertical screen configuration and tube cutting configuration are in object editing
area and 3D view bar.
Object editing area of vertical screen configuration is as shown in Fig. 1- 8.
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Fig. 1- 8 Object editing area introduction

Arris (Edge) length: depend on the radius and thickness of rectangular tube;
Extended face: correspond to the first face of actual tube, making it easy for users to draw graphs;
Center line: there is a center line on each face. When you drag graphs, the center of the graph can
adhere to center line automatically.
3D view bar: it includes 3D view area and view buttons. View buttons are as shown in Fig. 1- 9.

Fig. 1- 9 3D View Buttons
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1.4 Operation Procedures
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2 Software Functions
2.1 View Transformation
Pan

You can select “View” → “Pan” or click

in drawing toolbar, and then hold

down the left button of the mouse in the editing space, move the cursor to the
target position and release the mouse. Or just hold the mouse wheel and drag it.
You can select “View” → “Zoom”, or click

, or press +/- key in mini keyboard

Zoom

to zoom in or out the objects. Note that the actual size of the graphs won’t
change; only the view will be enlarged or minified. You can also slide the mouse
wheel in the “Object Editor Space” to zoom objects.

Zoom by Rect

You can select “View” → “Zoom by Rect” or click

in drawing toolbar to

enlarge part of an object to window size without changing its coordinates.
Fit to Window

View Mode

Catch Options

You can select “View” → “Fit to Window” or click

in drawing toolbar, or just

press * key in mini keyboard to make track view fit to window and get a general
view without sliding the window.
Wireframe mode: the default drawing mode, in which all objects are displayed in
wireframe.
Fill mode: in fill mode, objects are filled with a color.
You can click

in toolbar to enable or disable catch function. Besides, you

can set catch options by clicking

in toolbar.
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2.2 Graphic Operation
2.2.1

Load and Draw
1)

Load
2)
Draw

1)
2)

You can load a tool path program file by clicking sub-menu “Open”, “Import” or “Insert
file” under “File” menu.
You can also drag the program file to BodorPro icon or object editing area.
You can directly click corresponding icons on the drawing toolbar to draw graphs.
You can select a graph in gallery, set related parameters and load it into machining
files.

1)

After a file is imported, it will be automatically saved as .nce format file in folder “NceFiles” on the desktop.
The folder will be automatically created if there is none.

2)

When drawing a polyline, you can right click to select the type of polyline, i.e. line or tangent arc. After
drawing finishes, right click to select types to finish drawing.

3)

When drawing texts, you can press combination key Ctrl + Enter to make a line break, and press Enter to
finish inputting texts.

2.2.2

Different Ways to Select Objects

Select Unclose

You can select all the unclosed graphs in the tool path file by selecting submenu
“Select Unclose” under menu “Edit”.

Select Tiny

Click submenu “Select Tiny” under menu “Edit” and a dialog box will pop up. After
entering the ranges of X dimension and Y dimension of graphs and clicking “OK”,
you can select all the graphs in the range.

Select by Layer

Click submenu “Select By Layer” under menu “Edit”, and then click on a layer,
and you can select all the graphs in the layer. If there is no graph on a layer, the
layer will not be displayed in the layer list. For example, layer 5 is not displayed.

Select by Type

Click submenu “Select By Type” under menu “Edit”, and then click on a type, and
you can select all the graphs of the type in a tool path file.

Select by
Inner-Outer

Inner graph: graphs included.
Outer graph: graphs not included.
Click submenu “Select By Inner-Outer” under menu “Edit”, and then click on
“Inner” or “Outer”, and you can select the corresponding graphs.

Select Similar

Similar objects: objects of the same type and dimensions, but with different
position and rotation angle.
Select a graph and then click submenu “Select Similar” under menu “Edit”, and
you can select all the graphs similar to the graph you selected at first.
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2.2.3

Translate/Rotate/Scale/Align

Translate

After selecting objects, click “Object” → “Translate” or directly click on the selected
objects with mouse, and drag the objects to translate them. You can also make minor
position adjustment by pressing arrow keys.
Rotation changes position and direction and will not affect the shape. There are 3
methods to enable rotation function:
1) After selecting objects, click “Object” → “Rotate” to activate rotation mode. The

Rotate

2)

3)

Scale

first click point is the center of rotation, and included angle between the positive
X-axis and the straight line connecting second point and first point is the rotation
angle.
After selecting objects, press Ctrl, click one of the small rectangles around the
selected objects to enter rotation mode. In this way, the rotation center is located in
the center of the circumscribed rectangle of selected object by default. You can
drag the small circle to change the position of the rotation center.
After selecting objects, click “Angle” or “R” on the toolbar to input rotation angle and
press Enter.

The system supports auto scaling and interactive scaling in equal proportion.
Operations are as follows:
1) After selecting the objects, enter the scaling proportion in box “Scale”, and then
press Enter.
2) After selecting the graphics, select “Object” → “Scale”. The cursor will turn into
. Then specify scaling center in drawing area, and then move the cursor to
adjust scaling proportion. At last, left click on the mouse.

Align

2.2.4

There are nine align modes, including align to left, align to right, align to top, align to
bottom, align center point, align horizontal midline, align vertical midline, distribute
horizontally, and distribute vertically

Mirror

The system supports vertical mirroring and horizontal mirroring function. With mirroring function, you can
turn the object along the center line of symmetry horizontally or vertically. You can click

or

in

drawing tool bar to realize the function.

2.2.5

Array

With function Array, graphs can be arrayed in circle or rectangle. Below is an introduction of rectangular
array function.
After selecting graphs, click icon

, and a dialog box will pop up as shown in Fig. 2- 1. Set the rows,

columns, Y Dist, X Dist and Order, and click OK to confirm. After array function is executed, the new tool
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path will be loaded automatically. When you check the box “Auto delete common side when gap is 0”,
common side will be deleted automatically when the gap is 0.

Fig. 2- 1 Rectangular Array

2.2.6

Group/Break

You can bind two or more selected objects as a group with group function and dismiss a selected group
into multiple objects with break group function.
Take the operation of group function as an example. After selecting objects, click “Object” →
“Group/Break” → “Group”, or right click to open the shortcut menu and select “Group”, or click “Group”
button on the toolbar.

2.2.7

Combine

This option combines multiple unclosed objects (such as lines, arcs, elliptic arcs and unclosed polylines),
into one single-path object to realize integrated operations. It is recommended to open “Catch” function
before “Combine”.
To combine objects, click “Object” → “Combine” or right click to open the shortcut menu and select
“Combine” after selecting the objects. And then input an appropriate combine tolerance in the dialog box
popping out, click OK.

2.2.8

Explode

By exploding, you can delete extra lines to trim tool paths. For combined graphs, to explode
combinations equals to dissolve them. The result of exploding texts is the same as that of translating
texts to graphs. To explode objects, click “Object” → “Explode” after selecting the objects.
Explosion function is mostly used in polylines together with combine function. Combine correct graphs to
ensure machining quality.
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Fig. 2- 2 Effect of Exploding

2.2.9

Break

Break function is similar to micro joint function. With break function, the part machined will be joint with
surrounding material. You can also use break function to cut graphs during drawing graphs to get ideal
graphs.
To break objects, click “Object” →

“Break” after selecting the objects. You can select to break

automatically or manually according to your needs in the dialog box popping up. In automatically break,
you can break several graphs at the same time. In manually break, you can only break one graph each
time. The attributes of graphs will be changed after they are broken. The effect of break is as shown in
Fig. 2- 3.

Fig. 2- 3 Effect of Break

2.2.10 Measure Distance
This option is used to measure a certain distance. To use the function, select “Object” → “Measure” or
click

in drawing toolbar or select “Measure” in the shortcut menu.
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2.2.11 Shape Check
After importing or drawing objects, you can select this function to check the selected objects in the
currently loaded machining file to tell whether current path is normal or not.
Select the objects to be detected and click “Object” → “Shape check”. Select the boxes before “Closed
check”, “Self-cross check”, “Intersection check” and “Overlap check” according to your needs, and the
system will execute the corresponding checks. The click “OK”, the check result will be shown.

2.2.12 Shape Pre-process
Before formal machining, you need to pre-process the objects in the machining file, including clipping
overlaps, combining, deleting shorties (dots, mini-circles, and mini-curves), smoothening curves and
translating curves to polylines.


Instant Pre-processing

Click “Object” → “Shape Pre-process” → “Instant “Pre-process”, a dialog box as shown in Fig. 2- 4 will
pop up. Check the pre-processing items and set the parameter range to execute pre-processing. If
“Apply when import” is checked, objects will be pre-processed automatically when a machining file is
loaded. With “Simplify Polyline”, you can simplify graphs by reducing the control points of tool paths. The
effect of the function is remarkable in simplifying tool paths generated from .bmp file.

Fig. 2- 4 Instant Pre-processing

Besides, you can directly select “Shape Pre-process” →
pre-process the objects.


“Clip Overlaps”/”Delete Shorties” to

Curve Smoothing

With curve smoothing function, you can make curve smoother and easier to process.

Curve smoothing function is only supported for multiple polylines.
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Translate Text to Polylines

To convert texts to polylines, firstly select texts, and then select “Object” → “Shape Pre-process” →
“Translate Text to Polylines” or select “Translate Text to Polylines” in the shortcut menu.

2.3 Layer Setting
As the core function of BodorPro V2.0, layer function integrates the machining technics and general
parameters together into one interface so that you do not need to turn to parameter dialog box to modify
related parameters, bringing great convenience. Moreover, through presetting technics, better cutting
effects and higher efficiency can be achieved by simple setting on commonly used parameters such as
laser power, machining speed and so on.
Click icon

in drawing toolbar, a dialog box as shown in Fig. 2- 5 will pop out.

Fig. 2- 5 Layer Setting

There are altogether 8 colors for selection in the color window, with each corresponding to different
values of such machining parameters as speed, power, etc. Machining objects with the same color
shares the same values of machining parameters as default in BodorPro.

2.3.1

Set General Parameters

Click “General Parameters” to switch to general parameters interface, as shown in Fig. 2- 6.
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Fig. 2- 6 General Parameters Page

In this interface, you can set common parameters (including G00 speed, single axis acceleration and so
on), laser machine parameters and layer-related parameters.


Motion control parameters

In this part, you can set parameters related with motion control.
Parameter
G00 speed

Range

[0.06, Min. value of max. 30000
speed of each axis]
mm/min

Single axis acceleration
[100, 100000]
in positioning
Speed of simulate cut

Gxx Jerk

G00 Jerk
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10000
mm/s2

[0, Max. value of max. 30000
speed of each axis]
mm/min

Single axis acceleration
[100, 100000]
in machining
Cornering acceleration

Default

Description
The default speed when
positioning.
Single axis acceleration in
positioning.
Speed of simulate cut

5000 mm/s2

Single axis acceleration in
machining, see 3.4.1

[0.001, 100000]

5000 mm/s2

The maximum acceleration
when feed motion is on
adjacent two axes, see
3.4.2.

[0.001, 9999999]

100000
mm/s3

The rate of change of
single axis acceleration
when cutting.

[0.001, 9999999]

100000
mm/s3

The rate of change of
single axis acceleration
when positioning.

Parameter

Track smooth time

Range

[0, 0.064]

Default

0.02 s

[Min. speed of reference
Max. speed of reference
5000
circle, Min. value of max.
circle
mm/min
speeds of all axes]


Description
The longer the time is, the
smoother the workpiece
surface will be. But some
details may be weakened.
The maximal permissible
velocity of a circle with 10
mm diameter, see 3.4.3.

Laser Device Parameters

In this part, you can set the parameters related with the laser device.



Laser Device

You can select the mated laser machine and main stream laser types are
supported including SPI, IPG, Raycus, EO LIANPIN, MAX, ZKZM, and
TXSTAR. Among them, the sequence of opening laser gate for SPI and IPG
laser device is to open a laser gate 5 seconds after the laser device is open.

Serial
Communication

The serial port for communication with EX30A. And it can be connected to
COM1, COM2, COM3, and COM4. The option “None” means laser device is
connected to machine tool directly. Modification of the parameter can be
activated after restarting software.

Adjust Power Mode

It consists of duty ratio adjust and analog adjust. If duty ratio adjust is elected,
the speed power curve adjusts the duty ratio; if analog adjust is selected, the
speed power curve adjusts peak power.

Laser Power

It specifies the power value when laser power is 100%.

Min pulse width

It specifies the minimum allowable pulse width when laser power is controlled
by duty ratio. When pulse width is smaller than this value, this value is used.
When larger, pulse width in duty ratio is used.

Reset Laser

After laser device alarms are cleared, the laser device must be reset.

Burst Current

It corresponds to the peak power in burst.

Burst Frequency

It refers to the frequency light output by pulse in burst.

Burst Power

It refers to the duty ratio in burst.

Burst Time

It refers to the duration of laser during bursting.

Follow control
Frogleaping
Distance
Get Fixed Pos

Min.

When the distance is lower than this value, the system directly traverses to
the start point of the next object without frog leaping and uplifting cutting
head.
You can either click “Get fixed position” to set current Z-axis machine
coordinate as the fixed position or directly input the height position manually.

If follow height and three segment piercing height are lower than this value,
Directly follow the
the system will directly follow to the set height. If larger, however, the system
maximal height
will follow 1 mm and rise to the set height.

Quick Start「19」





Pressure control
Default blow type

It specifies the default gas when blow port is open, including air, nitrogen and
oxygen

Gas idle pressure

It specifies the pressure in idle state.

Switch gas delay

Mainly used in incremental piercing and segmented piercing, it refers to the
delay time for switching types of gas after piercing if cutting gas type is
different from that in piercing, with laser remaining on.

Gas on Delay

When blow port is switched from off state to on state, the system will execute
this delay time.

Task end motions
ZUP position

It specifies the target position to which the cutting head rises after machining.

XY axes actions

You can set the X and Y position after machining. Available options are: no
motion, back to workpiece origin, back to fixed position and to mark point.



Advanced



Cut film

When coated metal material is being cut, if its film is not removed, it will be melted and stuck to the
cutting head and the part. So cut film function is added, including “no film cut”, “cut one by one”, “cut by
groups”, and “cut globally”.
No film cut

It refers to direct cutting.

Cut one by one

Cut film before machining a single shape

Cut by groups

Cut film before machining a group of shapes and then execute the same
operation to the other groups.

Cut globally

Cut the film of all the shapes with one shot before actual machining

Since the machining parameters like film cutting power and cutting height are different from the actual
cutting parameters, the eighth layer is designated as the film cutting layer for setting proper film cutting
parameters.


Follow outside

Outside part height: the distance between cutting head and workpiece surface during leading in from
outside part. After setting the height, click “Set Outside Height” to confirm.

2.3.2

Set Layer Parameters

In this sub-interface, you can set the machining technics of a certain layer, such as the “Layer1” shown
above. This part includes saving/importing, technic parameters, special technic, power curve and
remark.


Save/Import

After the technic parameters and special technic are well set, you can save the custom parameters into
the technic library for backup by clicking “Save”. To call the saved parameters, click “Import”.
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Technic parameters
Pierce mode
Pierce directly

Procedure: open follow and blow → follow to “Follow height”, lasting “Blow
delay” time → “Pre-laser on delay” time → open the laser, lasting “Post-laser
on delay” time→ pierce finishes.

Increment

Procedure: open follow and blow → follow to “Pierce height”, lasting “Blow
delay” time → open laser, lasting “Pierce delay” time → keep laser on and fall
to the “follow height” in approaching speed → pierce finishes.

Pierce by segment

Procedure: open follow and blow → follow to “Pierce height”, lasting “Blow
delay” time → open laser, lasting “Pierce delay” time → pierce finishes.

Three segment

On the basis of the above pierce operations, this mode adopts increment and
pierce technics from burst height to the pierce height incrementally or in
segments. For more details, see the Appendix.

Cut parameters
Cut speed

It specifies the actual target cutting speed when federate override is 100%.

Cut current

It specifies the peak current corresponding to peak power in cutting setting
when the laser device is adjusted by the analog quantity.

Cut power

It specifies the average power in cutting setting when the laser device is
adjusted by PWM.

Cut frequency

It refers to the carrier frequency of PWM modulate signals in cutting, namely
the light emission times in one second. The larger the value is, the more
continuous the light emission will be.

Cut pressure

It specifies the auxiliary gas pressure in cutting and should be used together
with proportional valve or multi-valve.

Cut gas

It specifies the type of auxiliary gas used in cutting.

Cut focus

It specifies the position of focus in cutting, effective only in double Y and
double Y black configuration.

Pierce parameters
Increment speed

It specifies the speed used for falling from pierce height to the cutting height in
incremental piercing.

Pierce current

It specifies the peak current corresponding to peak power in pierce setting
when the laser is adjusted by the analog quantity.

Pierce power

It specifies the average power in pierce setting when the laser is adjusted by
PWM.

Pierce height

It specifies the distance between the pierce position and the workpiece.

Pierce frequency

It specifies the carrier frequency of PWM modulate signals in piercing. In
general it is set relatively lower and pulse is used to avoid bad piercing.

Pierce pressure

It specifies the auxiliary gas pressure in piercing and should be used together
with proportional valve or multi-valve.

Pierce gas

It specifies the type of auxiliary gas used in piercing.

Punch focus

It specifies the position of focus in piercing, effective only in double Y and
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double Y black configuration.
It refers to the duration of laser on at pierce height in incremental piercing
while the lasting time in segmented piercing.

Pierce delay
Delay parameters
Pre-laser off delay

It specifies the delay time before laser is closed.

Pre-laser on delay

It specifies the delay time before laser is opened.

Post-laser
delay

After laser on, the system will last this delay time before next step.

on

Others
Lifting height

The laser head will uplift this distance after cutting each object.

Pre-perforate lift

In pre-piercing, the cutting head will uplift this distance after piercing each
hole.

Follow height

It specifies the distance between nozzle and workpiece in cutting.

 Appendix: three-segment piercing
Three-segment piercing is usually used for thick sheets. Click “Three-segm”, and the three-segment
parameter sub-interface will appear.

Fig. 2- 7 Three Segment Parameters

As shown above, it is divided into three segments and you can set such parameters as increment speed,
current, frequency, power, pressure, height, focus, delay and extra blow for each segment respectively.
The system will execute three-segment piercing from the first to the third. If the box before any of the
three segments is unchecked, the system will skip this segment and the parameters below are disabled.
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Special Technic
Neglect This Layer

With this item checked, the system will not machine all the objects of
current layer by default.

Not Close Gas

With this item checked, the system will not close blow port when
machining all the graphs of the current layer by default.

Side Blow When Pierce

With this item checked, the system will open side blow port during
piercing by default.

Side
Blow
Machining

With this item checked, the system will open side blow port during
machining by default.

When

PrePerforate

With this item checked, pre-piercing function is valid for all the objects of
current layer. As to pierce mode, incremental piercing and segmented
piercing are recommended.

Enable Lead Speed

With this item checked, the lead speed is enabled.

Circle Overcut

It refers to overcut the acute angle and loop around to avoid over burn.
Check this item to enable this function and then enter the bypass angel
(0~150 deg) and overcut length (0.1~100 mm), click “OK” to complete the
setting.

Fixed Height Cut

After you “get fixed position” or manually input the fixed position height,
the system will remain this Z-axis coordinate in cutting.

Cool Delay

Laser off time at cooling point.

Outside Cutting

Commonly used in thick sheet or the part cutting with high requirement of
preciseness, it refers to cut the workpiece directly without piercing on it.

Cooling Gas

Different from cutting gas, including air, nitrogen and oxygen. It can
reduce cooling time and improve machining efficiency.

Power curve

The system provides power curve to solve problems such as over-burning around the corner and
difference of cutting result in terms of thickness. The laser power will change with speed accordingly so
as to ensure the consistency of thermal power absorbed in unit distance and achieve fine cutting result.
Click “Edit” under the curve sketch, “Edit” dialog box as shown in Fig. 2- 8 will pop out.
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Fig. 2- 8 Power Curve Edit

The left part of the edit box is the speed power curve, with cutting speed as the X-axis coordinate, the
cutting power as the Y-axis coordinate and percentage as the unit. Table of speed and power values are
on the right side, displaying all the speed and power values of the corresponding nodes at left side.
The system provides two methods to adjust power curve:


Method one: adjust directly on the curve

Double click on the curve box as per the prompt to confirm a node, with its corresponding speed and
power values shown in the right-side table. To delete a node, move the cursor onto it and double click it.


Method two: adjust by editing the table

By clicking on “Add” above the table, you can add a group of speed and power value in the table
automatically. Double click the newly added, input the value and press Enter to confirm. If you want to
delete a group of values, you can select the group and click “Delete” above. Besides, you can also click
“Clear” to restore the curve to default.
The more the nodes are confirmed, the more precise the curve will be. After the curve is confirmed, the
system will adjust the speed to the power automatically based on it without any other manual operation.
After the box before “Adjust power autom” is checked, the cutting power will vary with the cutting speed
and its concrete value is determined by the curve. The power in cutting will remain the same if “Adjust
power autom” is unchecked.

2.3.3

Set Across-arris Parameters

In tube cutting configuration, you need to set across-arris parameters for tube cutting.
“LayerN-Arris Parameters” sub interface is as shown in Fig. 2- 9. You can set parameters accordingly.
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Fig. 2- 9 Across-arris parameter setting

Current

Adjust laser device with analog, and set peak current during across-arris
cutting, corresponding to power during across-arris cutting.

Air pressure

Air pressure of auxiliary gas during across-arris cutting, used with
proportional valve or multiple air valves.

Frequency

Carrier wave power of PWM modulating signal during across- arris cutting,
i.e. laser emitting times in one second.

Follow height

The height from nozzle to par during across-arris cutting.

Power

The average power during across-arris cutting.

Sensitivity

The sensitivity of cutting head during across-arris cutting.

Across-arris speed

The cutting speed during across-arris cutting.

2.4 Technics
2.4.1

Set Lead Line

Click

in the drawing toolbar or select “View” → “Show lead in/out line” to display lead lines.

After selecting the objects, you can click

in drawing toolbar, or select “Tech” → “Lead Line” →

“Set Lead in/out Line” or select “Lead Line” → “Set Lead in/out Line”

in the shortcut menu. A dialog

box as shown in Fig. 2- 10 will pop out.
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Fig. 2- 10 Set Lead Line

Lead line type: including line, arc and hook. Hook lead line is made up by arc and line and only supports
leading in. There is no definite difference in the usage of line lead lines, arc lead lines and hook lead
lines, and they are interchangeable in practice. Lead line types are selected depending on cutting
technics. Lead line is used for precise machining.
If you set lead line to for unclosed graphics, the closed graphics area will be disabled and vice versa.
Adding tiny circle at lead in can solve the problem that slag accumulated during piercing thick sheet
influences cutting effect. The following introduces parameters in “Set Lead Line” dialog box.
Angle

It refers to the included angle between lead in/out line and tangent line in line
type and the center angle in arc type.

Radius

Hook radius refers to the radius of arc part of the lead-in/out line.

Length

In line and arc type, it refers to the length of cut-in edge or cut-out edge of
lead-in/out line while in hook type it sums the radius of arc and the length of
line.

Circle Radius

The radius of tiny circle at the start point of lead-in line.

Seal len

It ranges from -500 to 500. Seal length decides whether lead-in/out line is
cut-out or seal. In case of a negative value, under-cut will appear, i.e. this is
a cut-out lead-in/out line. In case of a positive value, over-cut will appear, i.e.
this is a seal lead-in/out line.

Seg No.

There are probable N straight lines (N is natural number) on the selected
object. ‘’Segment No.’’ refers to the sequence number of the segment where
the lead-in/out line is on among all the segments of the selected object (It is
used to fix the location of lead-in/out line on a certain segment). When it is
set as -1, “Pos Ratio” refers to the ratio of the distance between lead in/out
and the object origin to the total length of the object.
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Pos Ratio

It refers to the ratio of the distance between the position of lead-in/out line on
a segment and the beginning of this segment to the whole length of the
segment, and its range is “0, 0.999”.

Strategy

The selection of lead line start position, including edge first and corner first.

Simplified/Advanced

This button is to switch between simplified and advanced setting. Under
simplified mode, segment No. and position ration are not available.

Manual set

Left/right side

After this button is clicked, the mouse cursor turns into

. Also, you can

manually set lead line cut point by selecting “Tech” → “Lead Line” → “Start
Cut Point” or “Lead Line” → “Start Cut Point” under the right-click menu.
It mainly focuses on the unclosed objects. In terms of machining direction,
left side refers to leading in/out at the left side while right side means leading
in/out at the right side.

The effect sketch of five lead lines is as shown in Fig. 2- 11:

Fig. 2- 11 Lead Line Illustration

If a selected object is under “Unfill” mode, the system will select appropriate position to set lead in/out line and
cut the line properly to avoid overlapping.
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2.4.2

Set Machining Order

After clicking

on toolbar or selecting “View” → “Show Order”, you can view the machining order of

all objects.


Auto Set Machining Order

To set machining order automatically, firstly select more than one object, and then click “Tech” → “Mach
Order” → “Auto Set Mach Order” or select “Mach Order” → “Auto Set Mach Order” on shortcut menu.
Set relevant parameters in the dialog box popping up.


Manually Set Machining Order

Manually setting machining order inludes: setting the machining order, specifying the machining order or
customizing machining order lists. You can find the relevent menus under “Tech” → “Mach Order”.


Set Machining Orders

To set machining order manually, After you click “Set Machining Order” or select the button

on the

drawing toolbar or select “Set Machining Order” on the pop-up shortcut menu by right clicking mouse in
editing space, the mouse turns into

. At this time, click or frame select any object, and its machining

order will turn into 1, while the order of left objects will change to 2, 3,… sequentially according to the
original order. If you need to reset the last order number, you can select “Previous order” on the pop-up
shortcut menu by right clicking mouse in editing space.


Specify machining orders

Click “Specify Single Machin Order”, and set the machining order of the current selected objects in the
dialog box popping out. You can Note that an error message “More than one object selected, manual set
machining order is valid when only one object selected!” will be displayed if more than one object is
selected.


Machining order list

Select “Mach Order List”, and you can move up or down objects in the list in the dialog box popping up to
set machining orders.

During tube cutting, the system divides a machining graph into some sections by cutting edge, and machines from
bottom to top as default. You can set the machining orders in each section.
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2.4.3
Click

Set Machining Direction
in drawing toolbar or select “View” → “Show direction”, and machining directions will be

shown.
After selecting objects, click “Tech” → “Mach Direction” → “Reverse
Reverse machine
Direction”, or click “Mach Direction” → “Reverse Direction” in the shortcut
direction
menu. The machining direction will be reversed.
Set
machine
direction

2.4.4

After selecting objects, click “Tech” → “Mach Direction” → “Reverse Set
Direction”, or click “Mach Direction” → “Set Direction” in the shortcut menu.
And you can set machining direction in the dialog box popping up.

Set Kerf Compensation

Since kerf, i.e. the wearing part, exists in laser cutting, difference exists between the actually cut part
size and the theoretical part size. This difference leads to a smaller size in outer contour and a larger
size in inner contour. This system uses “kerf compensation” to compensate the geometry size.
After selecting objects, you can directly click
Compensation” or
will pop out.

in drawing toolbar, or select “Tech” → “Set Kerf

click “Set Kerf Compensation” in shortcut menu. A dialog box as shown in Fig. 2- 12

Fig. 2- 12 Set Kerf Compensation

Compensation type
Shrink

reserving the workpiece inner part.

Expand

reserving the workpiece outer part.

Expand or shrink

expand or shrink compensation based on the nesting relation.

Expand and shrink

reserving both inner and outer part of the workpiece.

You need to convert texts into graphs before setting kerf compensation.
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2.4.5

Set Unfill/Fill

You can select click “Tech” → “Unfill/Fill” to set unfill and fill cutting.

“Auto Set Fill” is default “Unfill” for tube cutting.

2.4.6

Instant Setting

Instant setting function is added to simplify operation steps, bringing you convenience.
After selecting objects, select “Tech” → “Instant Setting”, click

icon in drawing tool bar, or select

“Instant Setting” in shortcut menu. A dialog box as shown in Fig. 2- 13 will pop out.
In the dialog box, you can set fill or unfill, machining direction, lead lines, machining orders, and kerf
compensations. You can set the parameters according to your needs and then click “OK”.

Fig. 2- 13 Instant Setting
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2.4.7

Scan Cut

The system supports scan cutting of rectangular array or circular array of rectangles and circles, and Ad
filled tiny circles.
After selecting objects, click “Tech” → “Scan, and select line scan for rectangles, arc scan for circles, or
“Scan LED on Text” for Ad filled tiny circles. “Line Scan” dialog box is as shown in Fig. 2- 14. After setting
is done, click “OK” to begin scanning.

Fig. 2- 14 Line Scanning

 Related parameters
Parameter

Range

Default

Description

Laser on lead time for
[0, 10]
scan cutting

0

The time of open laser move forward, 1 for a
half control time.

Laser off lag time for
[0, 10]
scan cutting

0

The time of open laser move backward, 1 for a
half control time.

95

Modify the parameter when cutting track is
dislocated. Set it large when laser is turned on
early and set it mall when laser is turned on
late.

The buffer count for
[40, 128]
scan cutting

If part is not cut through when scan cutting begins and ends, you can set the above parameters.

2.4.8

Cooling Point

To improve cutting effect at corners of thick materials, the system provides cooling point function. With
this function, you can add cooling points at corners of the graphs. And laser will be closed when the
machine tool machines to the point. After “Cool Delay” time, laser is reopened and machining starts
again. In this process, blow port and follow-up function keeps open.
Click “Tech” → “Cooling Point”, and the cursor will become

. Then click on the corners of graphs to

set cool points as shown in Fig. 2- 15.
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Fig. 2- 15 Add Cooling Points

2.4.9

Release Angle

During bending process after cutting, cut out a fan-shaped area at the bending corner of bent part to
solve the uplift of material at the bending corner. Click “Tech” → “Release Angle”, and a dialog box will
pop out. After you specify the radius of release angle and the cursor turns into
angles.

, click to set release

Fig. 2- 16 Setting Release Angles

2.4.10 Chamfer
To improve cutting effect at corners of thick materials, the system also provides chamfer function. With
this function, you can chamfer angles less than 180 degrees for closed graphs.
After selecting objects, click “Tech” → “Chamfer”, or click “Chamfer” in the shortcut menu. A dialog box
as Fig. 2- 17 will pop up. After you set the chamfer angle range and radius of the arc, the system will
execute chamfer accordingly. Please note that settings can be different for negative chamfers and
positive chamfers. You can also only set the arc radius and select a point to chamfer with the mouse.
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Fig. 2- 17 Chamfer

2.4.11 Bridge
When a workpiece consists of multiple parts and you do not hope to scatter them after cutting, you can
connect them with bridge function. Besides, the function can also be used to reduce piercing counts. And
you can achieve “One-stroke” for all the graphics with the function. The function is mostly used in
connecting strokes of characters.
Click “Tech” → “Bridge”, dialog box “Bridge” will pop up. After setting “Max. Dis. Between adjacent
curves” and “Bridge Width”, click OK. The curser will change into

, and you can bridge graphs

according to your needs. The effect of bridging is as shown in Fig. 2- 18.

Fig. 2- 18 Bridging

2.4.12 Micro Joint and Explode Micro Joint
During laser cutting, the material is held by zigzag supporting rods. If the part machined neither can fall
from the gap of supporting rods nor can be held by the supporting rods, it will lose balance and become
warped. The high-speed moving cutting head may collide with the warped part. The best result will be
that the machine tool stops, and the worst will be that the cutting head be damaged. The situation can be
avoided with micro joint function. With this function, the part can be joined with surrounding material and
will not fall off, which will save sorting work.
Click “Tech” → “Micro Joint” or click

in the drawing tool bar, and a dialog box as shown in Fig.

2- 19 will pop out. There are two modes to setting micro joint, auto setting and manual setting. And auto
setting micro joint can be further divided into auto setting by counts and auto setting by intervals. You
need to select objects before setting micro joint automatically.
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Fig. 2- 19 Micro Joint

This system provides exploding micro joint function with which you can cut out redundant parts while
drawing complicated graphs. You can click “Tech” → “Explode MicroJoin” to explode micro joint. The
effect of setting micro joint and exploding micro joint is as shown in Fig. 2- 20.

Fig. 2- 20 Setting micro joint

2.4.13 Chop
The system supports chop function which can chop machining waste to make it fall off easily. After
selecting objects you want to chop, select “Tech” → “Chop”, and then set relevant parameters in dialog
box shown in Fig. 2- 21. The system provides two modes: by space, and by line count and column count.
Chop effect sketch is shown as in Fig. 2- 22.

Fig. 2- 21 Chop
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Fig. 2- 22 Chop Effect
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2.5 Nest
This function is used to nest objects. Click “Nest” → “Nest”, a dialog box as Fig. 2- 23 will pop out.

Fig. 2- 23 Nest Dialog Box



Parts

After selecting a part in “Parts” section, the sketch of the part will be displayed in the right. And you can
click “Edit” below “Parts” section to edit priority, rotate angle and nest count in the dialog box popping up.
You can also directly double click in the “Nest” dialog box to edit “Priority”, “Available” and “Rotate
Angle”.


Priority: the priority of the parts arrangement. The greater the number is, the higher the priority will
be. In case of insufficient material, the system will nest parts with higher priority first.



Rotate angle: the rotation angle of parts.



Count: the number of parts to be nested.



Materials

You can edit the materials to be nested. After selecting a material, click “Edit” below “Materials” section
and set the material name, count, width and height. You can also directly double click in the “Nest” dialog
box to edit “Available”, “Width” and “Height”.


Parameter setting

After “Setting” is clicked, a dialog box as shown in Fig. 2- 24 will pop up. You can set material margin,
part space, start corner and nest direction and nest algorithm. Nest algorithm includes “Remnant
Rectangle” and “True Shape”. “Remnant rectangle” is mainly used in nesting regular graphs such as
rectangles while “true shape” is mainly used in nesting irregular graphs.

「36」Software Functions

After setting the parameters, click “OK” and then click “Execute” to enable the function. The system will
execute nesting. After nesting finishes, the sheets section will display the nesting result, as shown in Fig.
2- 25. You can view the utilization rate of material in the section, and the nesting effect diagram in the
right of the dialog box. Then click “OK”. The nest result graphs will be loaded into object editing area.

Fig. 2- 24 Nesting Parameters Setting

Fig. 2- 25 Nesting Result
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If a dialog box as in Fig. 2- 26 pops up after you click “Execute”, it indicates that reading USB dongle failed. In
this case, you should check whether the USB dongle is well installed.

Fig. 2- 26 View Sheet

2.6 Teach
The software provides teaching function, with which you can draw machining paths manually according
to the shape and contour of workpiece.
Click

icon in drawing toolbar, a dialog box as shown in Fig. 2- 27 will pop out.

Fig. 2- 27 Teaching Dialog Box

Path No: a path is confirmed after started and ended.
Node No: a control point of curve to control the shape of curve, including linear node and circular node.
When drawing a line segment, a linear node is determined each time you click “End Point”. When
drawing a tangent arc, a three-point arc or three-point circle, a circular node is determined each time you
click “End Point” or “Point 3”.
Line: two points confirm a line.
Tangent arc: two arcs are tangent to each other or an arc is tangent to a line, with only one intersection.
Three-point arc: confirming an arc through three points.
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Three-point circle: confirming a circle through three points.

Path number and node number are calculated automatically by the system and manual modification is forbidden.


Operation steps

Take three-point arc as an example to illustrate the concrete operation steps:
1)

Select “3-Points Arc”, and then click “Start Path” to set current coordinate as the first point. If the
current point is not the desired one, move X and Y axes to the desired position before clicking “Start
Path” in order to set the desired position as the first point.

2)

After setting the first point, move X and Y axes to the next target position, then click “Point 2” to set
the second point,

3)

Move the axes to the third target position, and then click “Point 3” to set a three-point arc,
meanwhile, point 3 is also the first point of the next arc.

4)

Then operate as the same to confirm the second and third point of second, third…nth arc as
confirming the second and third point of the first arc and click “End Path” to complete.

During drawing, if you need to delete point 2, you can click “Back 1 Point”. But when an arc is confirmed
after clicking “Point 3”, you have to click “Back 1 Node” to delete the current third point because now the
third point is a node and “Back 1 Point” is disabled. “Back 1 Node” cancels the drawn third and second
point, with the first point remaining. To cancel the first point, click “Abandon Path”.
You can choose to manually move coordinates in jog or stepping mode. In jog mode, you need to press
numeric keys to switch manual high/low speed. In stepping mode, you need to click “Stop” to stepping
the motion of axes.

1)

After drawing you should click “End path”, otherwise the objects won’t be saved.

2)

With “Clear Track” function, you can clear the redundant red traces and keeps the useful blue ones.
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2.7 Follow-up Control
2.7.1

Hardware Connection

Fig. 2- 28 Connection Sketch of Follow-up System

Since the coat of preamplifier is used for shielding interference of signals, the outer metal part of preamplifier
surface should be well installed on the machine, as shown below. Refer to section 4.2 for details.
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2.7.2

Interface of Follow-up Control

Click “System” → “Follow Control”, or click

icon in the drawing tool bar, and a dialog box as

shown in Fig. 2- 29 will pop out. It includes system sub-interface and parameter sub-interface and both
are made up by function panel on the left and the fixed operation panel in the right.

Fig. 2- 29 Follow-up Control

 Operation panel
It consists of three areas and an E-stop button.


E-stop button: System E-stop. After system e-stops, the homing mark will disappear and homing
again is needed.

Coordinate display area: Displaying current
clicking mouse.
 Manual setting area
X+/X-: Manual button, corresponding to the number
key 6/4 respectively on mini keyboard;
Y+/Y-: Manual button, corresponding to the number
key 8/2 respectively on mini keyboard;
Z+/Z-: Manual button, corresponding to the number
key 9/3 respectively on mini keyboard;


or

, switchable through

: The button for choosing between jogging
mode and incremental mode. Click it to pop up the
pull-down menu as shown in the right.
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Function setting area

Follow

Calibrate

After the button is clicked, the system will run follow-up function automatically at
the presence of marking data. Click the button again to stop follow-up and move Z
to the up position. Click “Stop” button to end follow-up with Z remained at current
position.
After the button is clicked, the system will execute calibrating function
automatically. Click it again or press “Stop” to end auto marking.
After the button is clicked, Z-axis will go home automatically. Click the button again

Z homing

or press “Stop” to terminate homing. After homing finishes, mark

will appear

before Z-axis.
Stop

After the button is clicked, the system will cancel current motion and enter idle
state. It is used to bring the system to a normal stop in follow-up control.

If not going home, Z-axis will be lifted to safety height instead of returning to the up position after follow-up is
turned off.


Function panel



Main parameters
Follow Enable

After follow switch is clicked and the system runs following, follow enable is
opened.

Z Speed

Displaying current Z axis running speed.

Z Position

Displaying current Z axis machine coordinate.

Capacitance

The follow principle is to adjust the distance between cutting head and part
dynamically by measuring their capacitance. The smaller the distance is, the
smaller the displayed current capacitance (in actual frequency) will be. And when
the cutting head touches the part, capacitance value turns zero for metal part.

Follow height

It specifies the height in following and you can also modify it under “follow setting”
under parameter sub-interface.

Max speed

It specifies the maximum speed in following and you can also modify it in “speed
setting” under parameter sub-interface.

Sensitivity

It specifies the sensitivity of cutting head. Larger number mean more sensitive.
You can also modify it under “follow setting” under parameter sub-interface

Zup position

It specifies the target position of cutting head upward motion after machining and
you can also modify it under “Follow setting” under parameter sub-interface.

Only the latter four parameters can be modified. Clicking one will eject a dialog box, in which you input
the value and click “OK” to save it. Besides, you can also move the cursor on the right of the parameter
to be modified and click the appearing adjust arrow
tune its value.
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, taking follow height as an example, to



Oscilloscope

The oscilloscope illustrates three kinds of curves, including calibration data, real-time capacitance and
follow error.
Calibration data：As in Fig. 2- 30, X-axis coordinate shows the capacitance while Y-axis coordinate is
the distance between cutting head and part. Also called cutting head calibration, automatic calibration
measures the correlation between the capacitance and the distance between cutting head and part.

Fig. 2- 30 Calibration Data

Real-time capacitance ： It displays the capacitance real-time change curve in certain time shown by
X-axis coordinate. Keep the cutting head and part still and observe the “max.difference” reflecting the
difference between the maximum capacitance and the minimum one during this time in upper left, as
shown in Fig. 2- 31. The ideal value is no less than 8 and no more than 30. If the value is larger, the
interface will be more and capacitance measurement will be less stable.

Fig. 2- 31 Real-time Capacitance

Follow error：As in Fig. 2- 32, it shows the difference between actual follow height and specified follow
height and reflects the follow dynamic precision.

Fig. 2- 32 Follow Error
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Click anywhere within the coordinate will pause the curve change and turn the
Y-axis coordinate into

at the top of

.

Right click anywhere within the coordinate, a scale parameter box will pop out. Check “Auto Set Scale”
as shown in Fig. 2- 33, and the input boxes for scale setting are disabled. Uncheck “Auto Set Scale”,
will disappear from the top of the vertical coordinate axis. And you can set the minimal and unit
scales for horizontal and vertical scale. Click on the dialog box or press Enter to confirm the setting.

Fig. 2- 33 Scale Setting

2.7.3

Debugging Steps



Preparation

1)

Since improper setting of the parameters may lead to machine breakdown, so please read
parameter specification thoroughly before operation.

2)

Well connect the cutting head, preamplifier and CNC system, refer to section 2.7.1 for details.

3)

Please ensure that no abnormal alarm prompts and current capacitance is displayed with value
after opening the software.

4)

Confirm the Z-axis direction by clicking Z+/Z- manually to watch it move. Moving toward stands for
negative direction and the opposite is positive. If direction is incorrect, you can alter the value of
parameter “Axis direction”.

5)

To judge whether the dividing frequency ratio is set correctly, you can move Z axis in jogging mode
along positive or negative direction, watch corresponding stepping length change of Z-axis
coordinate and make a distinct between the increase and decrease of the changing value. If Z-axis
coordinate change is inconsistent with the specified step length, which indicates the dividing
frequency ratio is set wrong, you should modify its value. For more details, see section 2.7.4.
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6)

Correctly set the parameters in “system setting” to make sure basic motion and coordinate display is
normal and Z axis can go home without any problem.



Capacitance detecting

1)

Move the metal sheet to approach to the nozzle and check whether current capacitance varies in
real-time; when the cutting head moves downward and touches the metal sheet, the capacitance is
supposed to be zero.

2)

Set the parameter “Z up position” value properly.

3)

Move the cutting head to the position 2~3 mm far from the part surface, and keep the cutting head
still and observe whether the capacitance is stable (the ideal value is within 30). If the last three
numbers of the value fluctuate obviously, the electric interference is serious. Refer to section 2.7.4
for detailed solution.



Auto calibrating

The system provides metal and nonmetal calibrating. You can set follow-up parameter “Nonmetal mark”
as “Yes” to auto calibrating nonmetal material such as wood and plastic.
1)

Power on and warm up the amplifier every time the system restarts to ensure the inside of amplifier
is at normal working temperature. When the capacitance is detected stable, move the cutting head
to the position about 5 mm far from the part surface that should remain still. Click automatic
calibrating button, and the system will run calibrating automatically for 20 second. The whole
calibrating procedure can be divided into four steps:





Move the cutting head downward slowly to detect and touch part;
After it touches the part, lift it up 5 mm;
Again, move the cutting head downward slowly to detect and touch part;
After touching the part, the cutting head rises slowly in specified calibration distance. Meanwhile,
the system collects the calibration data and obtains the calibration curve.

Fig. 2- 34 Characteristic curve after calibrating

2)

In calibrating, E-stop button is suggested at any time in case of machine breakdown caused by
cutting head continuous moving downward if capacitance in touching part is incorrect, which can be
handled by referring to section 2.7.4.
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3)

After calibrating finishes, the curve displays promptly, with data stability and curve smoothness.
Stability is judged by the difference of the collected data between the segment of cutting head down
5 mm before touching part and that of cutting head up 5 mm after touching part. The larger the
difference is, the smaller the stability will be. If the stability is judged “bad”, the fluctuation may be
relatively more unstable and the external interference may be relatively more serious. You need to
calibrate again. Smoothness refers to the curve gliding property. “Bad” smoothness indicates the
curve is not flat with ups and downs or the rags, so re-calibratiing is required.


1)

Check follow-up
Set related parameters properly, including G00 speed, max. speed in follow, follow gain, Integral
coefficient, INposition tolerance and zero limit speed range (recommended value: Z G00 speed
9000 mm/min, max. speed in follow 20000 mm/min, follow gain 200, integral coefficient 1, INposition
tolerance 0.1 mm and zero limit speed range 0.05 mm).

2)

After calibrating succeeds, switch on and off the follow to observe whether the cutting head shakes
and whether the follow distance is correct;

3)

After following ends, you can move the bolt driver or tiny metal sheet back and forth under the
cutting head and see if it moves up and down along with position of bolt driver or the metal sheet
and if cutting head shakes.

4)

According to actual need, you can set the “Out margin check” as “Yes” and test if the function works;

5)

Draw a tool path and machine it without enabling laser, and see if the cutting head shakes in
follow-up process.

1)
2)

Enable “Out margin check” can improve safety effectively;
In cutting metal part, it is suggested to set parameter “Collide sensitivity” relatively larger if touching part
alarm occurs due to metal slag sticking to the nozzle.
You should set parameter “Nonmetal mark” as “NO” when cutting metal, otherwise follow-up precision will
be influenced.

3)

2.7.4


FAQ

Incorrect PG dividing frequency setting?

If PG dividing frequency ratio is set improperly, you need to modify its value. The setting method is as
follows.
WISE series servo driver:
Dividing Frequency Ratio 



Command Pulse No. per Moto r Circle
Output Pulse No. per Motor Circle  4  Mechanical Deceleration Ratio

Screw / P ulse Equivalence
Encoder Dividing Frequency Pulse No.  4  Mechanical Decel eration Ratio
Pr 008
Pr 011 4  Mechanical Deceleration Ratio
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Panasonic MINAS A5 series servo driver:
Dividing Frequency Ratio 



Command Pulse No. per Moto r Circle
Output Pulse No. per Motor Circle  4  Mechanical Deceleration Ratio

Screw / P ulse Equivalence
Encoder Dividing Frequency Pulse No.  4  Mechanical Decel eration Ratio
Pr 0.08
Pr 0.11 4  Mechanical Deceleration Ratio

YASKAWA Σ-Ⅴ/Σ-7 series servo driver:
Dividing Frequency Ratio 


Screw / P ulse Equivalence
Encoder Dividing Frequency Pulse No.  4  Mechanical Deceleration Ratio

Screw / P ulse Equivalence
Pn212  4  Mechanical Deceleration Ratio

DELTA servo driver
Dividing Frequency Ratio 


Screw / P ulse Equivalence
Encoder Dividing Frequency Pulse No.  4  Mechanical Deceleration Ratio

Screw / Pulse Equivalence
(P1  46)  4  Mechanical Deceleration Ratio

You can modify PG dividing frequency ratio by adjusting driver parameter values.


Serious electric interference?

Approaches to eliminate interference:
1) Check whether driver, lambda controller and external board EX30A are well grounded.(since the
driver position has influence on the electric interference, it should be connected tight with the
machine technically.
2)

Check whether the cable shielding layer treatment is complete and right, including shielding layer is
not broken and shielding nest is not wired to the outer metal frame.

3)

Check the No.4 pin of M16 tow cable with 4-core air plug and preamplifier is connected. The
resistance value between the two should be very small (like 0.01Ω), 0 best.

4)

Check whether the preamplifier and the machine are connected tight and complete (it is suggested
to polish and remove the oxide coating of the touching side by abrasive paper before installing
preamplifier).

5)

Test whether the cable work through multimeter.

6)

The machine is well grounded.

Adjust in software:
1) Reduce sensitivity slightly;
2)

Increase the values of “In position tolerance” and “Zero limit speed range” slightly.

Reducing the sensitivity value may lead to lower precision and turning up the values of “In position tolerance”
and “Zero limit speed range” may give rise to cutting inaccuracy, so please operate carefully.
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Capacitance value is not zero in touching part?
Cause

1)
2)
1)

Solution

2)
3)



The actual follow height is different from the calibrated follow height?
1)
Cause
2)
Solution



The part and the machine are not connected or not well connected;
Insulator such as rust and paint exists on the part at calibrating position.
Move the cutting head downward and toward the part, and then jiggle the step
length manually;
Use small step length such as 0.1 to drive the cutting head downward until it
touches the part and check current capacitance;
Set the parameter “Touch part capacitance” larger than current capacitance.

After system restarts, the amplifier is not warmed up to make the inside
temperature reach normal working temperature. Therefore, the calibration
curve of capacitance is unstable;
The environment temperature changes enormously, which cause the deviation
of calibration curve of capacitance.

Re-calibrate.

Cutting head keeps moving downward during calibrating?
1)

The capacitance in touching part is not zero and refers to solutions mentioned
above;
2) There exist program errors in Lambda 5S or the terminal board EX30A. You
need to contact the manufacturers to change another one.
Judging method: move the metal sheet to touch the nozzle. If the capacitance is not
zero, there exist program errors in EX30A. If the capacitance is zero without any
touching part alarm, program errors occur in Lambda 5S.
3) Installation problem.
Delete file folder “BodorPro” under C:\Program Files\Bodor and reinstall. If you
choose to put the parameters separately in previous installing, it is also required to
delete the Bodor folder under D disk (first back up what needs to be saved including
software package, technic library and so on).

Cause

Solution

2.7.5

Follow-up Control Parameters
Parameter

Range

Default

Effecting

System Setting
Axis direction
Pulse equivalent

1

After restart

[1E-08, 1000] mm/p

0.001

After restart

The displacement and angle of one control pulse in the corresponding
feeding axis.

Lower
limit
worktable stroke

of

Upper
limit
worktable stroke

of

Frequency
ratio of Z

1: positive; -1: negative

[-999999, Upper limit) mm

-3000

After restart

(Lower limit, 999999] mm

1

After restart

-

-1

After restart

dividing The ratio between the sending pulses and feedback pulses of Z axis.
Positive value stands for forward direction of axis encoder while negative
value for backward direction. Note that this value cannot be set as “0”.
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Parameter

Range

Default

Effecting

1: positive; -1: negative
1
Immediately
Z direction in coarse
The moving direction of Z axis in coarse positioning stage when backing to
positioning
the reference point.
[0.06, 9000] mm/min
1800
Immediately
Z speed in coarse
The feeding speed of Z axis in coarse positioning stage when backing to
positioning
the reference point.
[-100, 1000] mm

2

Immediately

The additional displacement of Z after precision positioning when backing
to the reference point. Positive value represents backing inside, and
negative value represents backing outside.

Back space of Z
Follow-up

[0, 20]
Sensitiveness

10

Immediately

A larger value means a more sensitive following. But a too large value may
cause overshoot.
[0, 65535]

Ki

50

Immediately

An integral coefficient which can reduce follow balance.
[0, 999999999] ms

0.1

Immediately

The parameter controls the jumping of capacitance. The value is larger, the
ability to control jumping of capacitance will be stronger. But the sensitivity
of capacitance will be lower.

Prefilter value

Yes: Enable; No: Disable

Enable dynamic
anti-shake

Yes

Immediately

Whether to enable dynamic anti-shake in order to control follow shake
caused by operations such as blowing.
[0, 655] mm

INposition tolerance

0.1

Immediately

When detected height is equal to “Follow height ± INposition tolerance”,
follow is in position.

Zero
range

limit

speed [0, 0.1] mm

0.05

Immediately

Within this range, following motion will not be adjusted.

Mark Setting
Yes: Enable; No: Disable

Nonmetal mark
Touch
capacitance

Touch part speed
Mark speed

Immediately

0

Immediately

Enable nonmetal calibrating.
part

-

It specifies the capacitance in MHz when touching the parts.
[0, 25] mm

Mark length

No

15

Immediately

Record the capacitance data in this range. Set the value small when the
travel of Z axis is short.
[0, 10000000] mm/min

100

Immediately

It specifies the speed in touching part during calibrating.
[0, 10000000] mm/min

100

Immediately
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Parameter

Range

Default

Effecting

Follow Setting
ZUP position

-10

Immediately

It specifies the machine coordinate of Z up position after following is
disables or homing finishes.
[0,100] mm

Safety height

10

Immediately

Safety height when Z axis is not back to mechanical origin.

Follow height

[0, 30] mm

1

Immediately

-

Yes

Immediately

Real-time state check
Out margin check

It specifies whether to enable the check for moving out of range in
following. If out of range, the machine stops.
[0, 20] mm

Out margin tolerance
Out margin sensitivity

2

If current position is out of tolerance range compared to the follow height
position, the system considers it beyond margin.
[1, 10]

5

Immediately

A larger value may lead to higher tendency for judging out margin.

Speed Setting
[0, max. speed of Z] mm/min

15000

Immediately

Cutting head speed in moving up and down. When G00 speed is too great,
you need to add mark length accordingly for cutting head to slow down,
avoiding bumping into part.

Z G00 speed

Max speed in follow

[0, Max Speed of Z axis] mm/min

20000

Immediately

Max speed in follow should not exceed the maximal speed of Z axis.

20000
Immediately
Max speed supported [60, 3932100] mm/min
by Z
Note that the follow speed and G00 speed should not exceed this value.
Follow acceleration

-

10000 mm/s2

Immediately

[0, 10000000]

800 mm/s2

Immediately

Manual Speed(Z)
Manual
of Z

acceleration

Manual high speed

[Manual low speed, the min between Max
1800
Z axis speed and 9000] mm/min

Immediately

Manual low speed

[0.06, Manual high speed] mm/min

1200

Immediately

[0, 65535]

100

Immediately

Follow Outside Part
Max Kp in
outside part

follow

In outside follow, Kp value is limited within this parameter range to avoid
following too fast and plunging too deep.
[0, 5] mm

Max. plugging depth
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0

Immediately

The Max. allowable plugging depth of the cutting head relative to the part
surface. If the actual plugging depth exceeds setting value of the
parameter, the cutting head will be outside the part and it should be lifted.

Parameter

Range
[0.01, Reference height out margin] mm

Default
1.5

Effecting
Immediately

Reference height in If current capacitance stays smaller than that corresponding to this
margin
parameter value during the sense delay, the system considers it within
margin and enables follow.
[1, 500] ms
Sense delay in margin

10

Immediately

It specifies the needed delay time for detecting whether within margin.
Excessively large value leads to lag in follow while the contrary will make
response too sensitive.
[Reference height in margin, 20] mm

5

Immediately

Reference height out If current capacitance stays larger than that corresponding to this
margin
parameter value during the sense delay, the system considers it beyond
margin and disables follow.
[1, 500] ms
Sense
margin

delay

50

Immediately

out It specifies the needed delay time for detecting whether beyond margin.
Do not set a too large value for this parameter, otherwise out margin detect
will be insensitive, leading the cutting nose to plunging too deep.
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2.8 Tube Cutting
In tube configuration, the system supports circular tube cutting and rectangular tube cutting. Tube cutting
workflow is as shown below.

2.8.1

Set Tube Dimensions

Select “System” → “Tube Cutting Setting”, and open tube setting dialog box, as shown in Fig. 2- 35. You
can set tube type and relevant dimensions in it according to your needs.
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Fig. 2- 35 Tube cutting setting dialog box

As for radius of rectangular tubes, you can set it 0.5 mm larger than the original data, to avoid rotating stop during
cutting of arrises due to dimension setting deviations.

2.8.2

Leveling and Centering

Leveling refers to adjusting tubes to horizontal state, and centering refers to find the center line of a face
of tubes. Since shape of tubes is different, rectangular tubes must be leveled and centered before being
machined, while circular tubes only need to be centered before being machined. Thus cutting effect can
be ensured. Taking rectangular tubes as an example, principles of leveling and centering are introduced
as in Fig. 2- 36 and Fig. 2- 37.

Fig. 2- 36 Principle of leveling
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Fig. 2- 37 Principle of centering



Rectangular tubes

Level centering: level centering is made of two functions, leveling and centering. Leveling is executed
before centering, and the operations are executed only on the first face.
Operation details: rotate the rectangular tube to the wide face, and click “Top Center” button on machine
control bar. The system will execute leveling and centering.
Four-face centering: based on level centering, the system also needs to execute leveling and centering
to other three faces, to ensure cutting effect.
Operation details: click “Faces Center” button on machine control bar, and the system will execute
four-face centering.
Pivot compensation: pivot compensation function can solve the problem that the center line of
unfolded tube in software does not coincide with that of actual tube. With pivot compensation function,
the error between tube dimensions and assembly clamp can be compensated. The error can be within
0.2 mm after being compensated.
Operation details: click “System” →

“Tube Cutting Setting” →

“Pivot comp…”, and the pivot

compensation dialog box will pop out, as shown in Fig. 2- 38. The pivot compensation data in the boxes
are generated automatically by four-face centering function. You can also set them yourself. The
software display will be different whether check “Auto comp”
Non-auto compensation: uncheck “Auto comp”, and set the compensation parameters automatically or
manually. The center line of each face offset according to the compensation data. At this time, when
move the pivot of a graph to the center line, it will adhere to the center line. The compensation will not be
executed during generating tool path. Sketch of non-auto compensation is as shown in Fig. A below.
Auto compensation: check “Auto comp”. The center line of each face will not offset, but tool path will be
compensated during machining. Cross-face graphs will not be compensated. Sketch of auto
compensation is as shown in Fig. B below.
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Fig. 2- 38 Pivot compensation dialog box



Circular tube

Only centering is needed for circular tube cutting.
Operation details: click “Top Center” in machine control bar, and the system will execute centering for
circular cutting.

2.8.3

Prepare Tool Path

You can load tool paths file or draw directly in object editing area, referring to section 2.2. Also, you can
use tube cutting wizard to generate tool path automatically. Since it is difficult to set tube cutting angle,
we suggest that you use tube cutting wizard.
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Click

in drawing tool bar to open tube cutting wizard dialog box. You can set relevant parameters

according to your needs and click “Create Curve”. The system will load the path automatically. You can
use the wizard to generate five types of tool path, i.e., circular tube intersecting, circular tube cutting,
rectangular tube cutting, elliptic tube cutting and waist tube cutting.

2.8.3.1

Circular Tube Intersecting

Circular tube cutting can be divided into two types according to hole types.


Circle hole

Parameters for circle hole intersecting are as shown as Fig. 2- 39.

Fig. 2- 39 Circle Hole Cutting

Rev axis

Under rotary table configuration, rotary axis is fixed.

Primary dia

The diameter of primary circular tube, like “D” in the above picture.

Auxiliary dia

The diameter of auxiliary circular tube, like “d” in the above picture. Manually enter
the auxiliary diameter which must be less than or equal to primary diameter, when
cutting the primary circular tube.
The offset between center line of primary circular tube and auxiliary circular tube,
like “e” in the above picture.

Distance

Max. Offset Distance  

The tilt angle ([5, 175]) between intersected primary pipe and auxiliary circular tube,
like “A” in the above picture.

Angle
Primary
Auxiliary

Primary Dia.  Auxiliary Dia.
2

or

Including single hole cutting, pair hole cutting and auxiliary tube cutting.
“Cutting Pos” can be used to cut multiple circular holes on a round.

Cutting Pos

X: the angle X axis rotates in rapid traverse with respect to the last cut hole.
Y: the length Y axis moves (i.e. to the next cut position) in rapid traverse with
respect to the last cut hole.
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Fig. 2- 40 ~ Fig. 2- 43 are trajectories of different tube hole cutting types.

Fig. 2- 40 Trajectory of Cutting Single Primary Circular Tube

Fig. 2- 41 Trajectory of Cutting Pair of Primary Circular Tube

Fig. 2- 42 Trajectory of Cutting End Face of Auxiliary Circular
Tube

Fig. 2- 43 The Trajectory to Cut Several Circular Holes on A
Primary Tube



Rectangle hole

It is similar with the circle-hole type, except for some different parameters, as shown in Fig. 2- 44.

Fig. 2- 44 Intersectional Cutting-rectangle Cutting

Length

The size of rectangle edge parallel to the edge of round tube.

Width

The size of rectangle edge perpendicular to the edge of round tube.
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Tilted angle

Tilt angle of “Length” edge with respect to the center line of round tube, which can
be used to cut multiple rectangle holes on different parts of round tube at different
angles. If “Tilted Angle” is positive value, tilt goes CCW; if negative, title goes CW.

Other parameters are the same as those of circle cutting.


Multi-cutting of Round Tube

The software supports cutting multiple objects on a round tube, with the concrete methods as follows.
1)

Draw or import the objects to be cut.

2)

Select all the objects and then select “Object” → “Set Intersecting Line” or select “Set Intersecting
Line” in shortcut menu. (Setting “Intersecting Line” for each object is also OK, but too cumbersome.)



Axis: consistent with current rotary table configuration.



Pipe Dia.: the diameter of current pipe, which must be larger than the maximum height of all objects,
or an error prompt will pop up.



Precision: the contact ratio of actual cutting path and pre-estimated path; the smaller the Precision
is, the smaller the error will be.

3)

After setting the above parameters, click “OK” to generate the motion trajectory.

After all operations above are finished, the system will cut the required object holes on the round tube
according to the above motion trajectory.

2.8.3.2

Circular Tube Tilted Cutting

Parameters for tilted cutting are as shown in Fig. 2- 45.

Fig. 2- 45 Tilted Cutting Dialog Box

Rev axis

The rotary axis under current rotary table configuration.

Tube dia

The value set in the system parameter “Rotation Diameter”.

Angle

The angle ([5, 175]) included by cutting face and circular tube center line, like “A” in
Fig. 2- 46.
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The trajectory of circular tube tilted cutting is as shown in Fig. 2- 46.

Fig. 2- 46 Trajectory of Circular Tube Tilted Cutting

2.8.3.3

Rectangular Tube Cutting

Parameters for rectangular tube cutting are as shown in Fig. 2- 47.

Fig. 2- 47 Tube cutting wizard--rectangular tube cutting

Weld compensation refers to compensation for shrink of weld joint. The system provides three types of
weld compensation, i.e., curve across arris compensation, straight arris overcut compensation and joint
space compensation. Effects of the three compensations are shown in Fig. 2- 48.
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Fig. 2- 48 Rectangular tube cutting---weld compensation effect

Weld compensation cutting tool path drawn with tube cutting wizard---Set weld joint space.
Weld compensation cutting tool path drawn with tube cutting wizard---Set straight arris
overcut.
Weld compensation cutting tool path drawn with tube cutting wizard---Set curve across
arris.
Weld compensation cutting tool path drawn with tube cutting wizard---Weld joint space
and straight arris overcut not set.

2.8.3.4

Elliptic Tube Cutting

Parameters for elliptic tube cutting are similar to that for circular tube cutting.

2.8.3.5

Waist Tube Cutting

Parameters for waist tube cutting are similar to that for circular tube cutting.

2.8.4

Set Machining Position

Circular tube cutting: since machining areas for circular tubes have no limit, you can move graphs in tube
height area.
Rectangular tube cutting: the center of a graph will catch center line automatically when it is being
moved. Please ensure you move graphs inside tube in object editing area. Otherwise, the system cannot
execute machining and will prompt “Convert to 3D toolpath failed!” in status bar.
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2.9 Machine Tool Functions
2.9.1

Edge Finding

Click “Mach” → “WCS Adjust”, or click

icon in drawing toolbar, and a dialog box as shown in Fig.

2- 49 will pop up. Check “Use work coordinate adjust” to enable the function.

2.9.1.1

Types of Edge Finding

There are three edge finding types available in the system, namely two-point edge finding, three-point
edge finding and auto edge finding.
Two-point edge finding: set point O’ at the bottom left of material as the origin of new workpiece
coordinate system, and then set point A in the positive direction of X-axis; thus, the new X-axis can be
determined with O’A. The software automatically will determine the new Y-axis by drawing a line
perpendicular to line O’A through O’.
Three-point edge finding: take the bottom left corner of material as the origin of WCS, set point A and B
in the positive direction of X-axis to determine the new X-axis, and then set point C in Y-axis. The
software automatically will determine the new Y-axis by drawing a line perpendicular to line AB through
point C. The foot O’ is the origin of new workpiece coordinate system.
Auto edge finding: see 2.9.1.3.

Fig. 2- 49 WCS Adjust

Machining Debugging「61」

2.9.1.2

Steps of Edge Finding

Take two-point edge finding as an example.
1) After selecting “Adjust Type” as “Two points”, manually move X and Y axes to point O’ at the bottom
left of the part, then click “Set O’” to set O’ as the origin of new WCS.
2) Then move X-axis towards positive direction to set point A, and set line O’A as the X-axis of new
WCS. At this time, the software will determine the new WCS automatically based on point O’ and A.
3) Click “Calculate=>”, and the software will automatically calculate the rotation angle of current
material with respect to machine coordinate system, so that the software will automatically rotate
the WCS in the tool path by the corresponding angle. If the rotation angle is greater than 15 degrees,
it indicates that the workpiece is not put well, and you need to re-place the material before edge
finding again. If coordinates of O’ and A are not accurate or need to be abandoned to set new points,
you can click “Reset O’A” to restore the coordinates of O’ and A to default.
Manually move coordinates in jog or incremental mode. Number keys 4, 6, 2 and 8 on the keyboard are
respectively corresponding to X-, X+, Y- and Y+. Combination key can also be used. For instance, when
0 and 4 are pressed simultaneously, the spindle moves towards the negative direction of X axis at rapid
jogging speed. However, when only 4 is pressed, the spindle moves toward the negative direction of X
axis at jogging speed.

1)

Before locating a point, you should open lead light first to guide the locating position.

2)

In three-point edge finding, point A, B and C should be in the positive half of X-axis and the X-axis
coordinate value of A should be smaller than that of B, otherwise the axis direction will be reversed.

3)

The result of edge finding will be cleared automatically after machining ends normally, so the rotation angle
will be regarded as 0 degree if no edge finding executed before next machining. Note that the data of last
edge finding will not be cleared in the software interface. To continue using the data for machining, select
“Use work coordinate adjust” and then click “OK”.
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2.9.1.3

Auto Edge Finding

Fig. 2- 50 Auto WCS Adjust

Operation steps of auto edge finding are as follows.
1) Set edge finding parameters, including X offset, Y offset, follow height, edge finding speed and
material dimensions.
2) Manually move the cutting head above the material.
3) Click “Start” to execute auto edge finding. The system will judge the long edge and short edge
according to material dimensions. Firstly set point C: enable follow-up at the current point → move
to the short edge in edge finding speed and set the out point as point C; then set point A and B:
move to 20% from long edge boundary and enable follow-up. → move to long edge and set the out
point as point A. → move to 20% from another long edge boundary and enable follow-up. →move
to long edge and set the out point as point B.
4) After auto edge finding is finished, X-axis and Y-axis return to point O’ in the bottom left of the
material.

2.9.2

Cyclical Machining

Select “Mach” → “Cyclical Machining”, and a dialog box as shown in Fig. 2- 51 will pop up. You can
enable the function by click “Enable” or “Auto Cycle” to enable cyclical machining function. You can set
the times and interval of the cycle machining.
Cycle machining can also be executed in dry run mode.
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Fig. 2- 51 Cyclical Machining Info

Only after the “Enable” is checked, the cycle machining function is activated and input is available.
“Dones” shows the current processed times in real time. After “Times” is finished, it needs to be cleared
manually. If “Pause” or “Stop” is pressed before “Times” finished, the number behind “Dones” indicates
the actual cycle times finished at present. “Cycle times” is counted once after one complete execution of
the file.

2.9.3

Exchange Workbench

In double Y configuration and double Y focus control configuration, the system provides exchange
workbench function, which can shorten the loading and unloading time, thus improving production
efficiency. There are two exchanging workbench modes, i.e. exchanging workbench automatically and
manually. To enable the function, you should set parameter “Enable Exchange Workbench” to “YES” and
restart the software to make it effective. After the software is restarted, in the bottom of machine control
bar, two icons will be added as shown below. And the corresponding ports will be displayed in “Io Ports”
dialog box.
The system will start exchanging workbenches when you turn on the switch button.
The system will output “Machine Bed Clamp Valve” signal to release machine bed when
you turn on the switch button.
Exchange workbench manually: after you can ensure the wiring of ports are correct, input “Workbench
Jog Forward (LowerIn)” and “Workbench Jog Backward (UpperIn)” signals or press the respective
buttons on the machine tool.
Process flow of exchanging workbench: execute exchanging workbench → Z-axis returns to machine
origin → output “Machine Bed Clamp Valve” signal and release machine bed → machine bed released
signal detected and releasing finished → executing upper workbench in and lower workbench in →
deceleration position detected and decelerate the exchanging workbench speed → stop position
detected and exchanging workbench is finished.

2.9.4

Auto Exhaust

Since there is large amount of smoke produced in high-power laser cutting, fans can be installed below
the machine tool to exhaust the smoke. The system provides six ports for exhaust function: exhauster
port 1~3. You need to set parameter “Enable auto exhaust” to “YES” to enable the function.
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Workbench stroke range of Y-axis is divided into three equal segments according Y-axis stroke. The
segments area are identified intelligently and sent corresponding signals during machining. For example,
when machining in area 1, output at port exhauster port 1. Extend 5 cm in front and behind the dividing
line as the dividing line area of adjacent areas. In dividing line areas, signals of adjacent areas can both
be received. You can also customize exhausting interval according to your actual needs.

 Related parameters
Parameter

Range

Description

Enable auto exhaust

YES: enable; NO:
YES
disable

Whether to enable auto exhaust function.

Disable Exhaust Delay

[10, 10000] ms

Delay time before disabling exhaust port
when leaving out of the area.

Start
position
exhausting

2.9.5

1000

of [Lower limit of Y,
0
Upper limit of Y]

Exhausting interval 1~3



Default

[10, 10000]

1000

Starting position of exhausting area, in
machine coordinate.
The length of No. 1~3 exhausting area.

Return to Mark Points and Fixed Points

Return to mark points

This function is used to set the machine coordinates of target position as mark points so that the
machine can return to the mark points in need.
Click “Mach” → “Mark Position” or click

icon in drawing toolbar, a dialog box as shown in Fig.

2- 52 will pop up.

Fig. 2- 52 Mark Point

1)

Set mark points

After you click direction buttons in machine toolbar or press the shortcut keys to move the machine tool
to the target position, select mark point number ranging from 1 to 8. Then click “SetMark” in the dialog
box or click “Set Mark” button in machine control area. The current machine coordinate will be set as
mark point.
2)

Return to mark points

When needing to return to mark points, select mark point 1~8, and click “GoMark” in the dialog box or
click “Go Mark” button in machine control area, the system will return to the selected mark point.


Return to fixed points

After machining ends, the machine can return to the fixed position.
1)

Set fixed points
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Click “Mach” → “System Parameters” and set the machine coordinate of fixed point in “1.1 FixedPoint”.
It is zero by default.
2)

Return to fixed points

After setting, click “Backtofixedpoint” under “Mach” menu, the system will return to the fixed position.

 Related parameters
Parameter

Range

X machine coordinate

[-99999, 99999]

0 mm

X-axis machine coordinate of the fixed point.

Y machine coordinate

[-99999, 99999]

0 mm

Y-axis machine coordinate of the fixed point.

2.9.6

Default

Description

Lubricate

The lead screw of machine tool should be lubricated after a period of machining time. So the software
provides manual lubrication and auto lubrication function. Before using the function, you need to modify
manufacturer parameter “Enable Lubricate” to enable lubrication function and select a lubricate mode.


Auto lubrication

When parameter “Enable Lubricate” is set to “1”, the system will lubricate automatically. You only need to
set parameter “Lubricate Len” and “Lubricate Time”. The system will turn on lubrication port
automatically for “Lubricate Time” after running “Lubricate Len”.


Manual lubrication

When parameter “Enable Lubricate” is set to “2”, you need to execute lubrication manually. Select
“Mach” → “Lubricate”, and a dialog box as shown in Fig. 2- 53 will pop out. You can set start point, end
point and lubrication speed. Click “Start” after you have finished setting.

Fig. 2- 53 Lubricate

 Related parameters
Parameter

Range

Enable Lubricate

0: No; 1: Auto; 2: Manual

0

The modes of lubrication.

Lubricate Len

[1, 999999] m

100

The run length of turn on lubrication once.

Lubricate Time

[1, 100] s

5

The duration time of lubrication.
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Default

Description

2.9.7

Show Power

After clicking “View” → “Track” → “Show feedback track”, you can select “Mach” → “Show power” to
turn the cursor into

and then move the cursor on the feedback track to display the power value of

current position, Fig. 2- 54. Power display function should be used together with the feedback trace. You
can adjust the power curve through the displayed power in feedback trace to get a proper curve and
solve over-burning in corners, achieving ideal cutting effect. See 2.3.1 for how to edit power curve.

Fig. 2- 54 Show Power

2.9.8

Focus Control

Since cutting of different materials have different focus requirements, and different focuses are used in
cutting and piercing to ensure cutting effect. In actual machining, you can set focus related parameters
such as cutting focus and punch focus in layer setting interface.
To use focus control function, set parameter “Enable focus control” as “YES” and then select “System”
→ “Focus Control”. A dialog box as shown in Fig. 2- 55 will pop up.
Locate speed: The speed in locating focus.
Jog speed: Jog speed when adjusting focus with button
and

.

Focus offset: The position of focus after returning to machine
origin.
Focus position: The current position of focus.
Locate: Locate to the focus position at positioning speed.
Home: W-axis returns to machine origin.
Fig. 2- 55 Focus Control

Stop: W-axis stops moving.
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2.10 System Management
2.10.1 Generate Parameter Backup Installer
With this function, the software can be backed up into .zip format file to the default path (D:\Bodor\Setup),
which is very helpful for saving adjusted parameters. You can find the sub-menu “Make Param Backup
Installer” under menu “System”.

2.10.2 Language Setting
At present, the system supports Chinese and English. You can switch the languages either at software
installation or after the software is started. For the latter situation, you can choose “Language” under
“System” menu.

2.10.3 Log
Sub-menu “Log” under “Manage” menu records important operation and system time. In this interface,
you can view not only the log information after current startup, but also the history logs.

2.10.4 Machining Statistics
By clicking “Manage” → “Show statistics” menu, or directly clicking the report button in the bottom of the
software, you can view such information as program file name, number of holes, cutting length, elapsed
cutting time, total machining time, times of cycle machining, MP time, etc.
If you need to calculate the charges, select the machining info and click “Charging” button. Cutting cost
can be automatically calculated and offered when unit prices of hole perforation and cutting have been
inputted.


Machining count

The system supports machining count function. Click “Count” button in report bar, and a dialog box as
shown in Fig. 2- 56 will pop out. Before using the function, check “Enable counting”. Then you can set
planned count and end actions. During machining, machining count will add 1 after a file is processed
completely or completed after breakpoint resuming. After a new file is imported or file name is changed,
the finished count will reset to zero.
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Fig. 2- 56 Machining Count

2.10.5 Help
You can view help information including users’ manual, shortcut key and daily tips under “Help” menu.
After BodorPro is open, daily tips dialog box pops out automatically in default. Or you can click “Help” →
“Daily Tips” to open daily tips. This function lists various operations and functions in software operation
sequence. You can click “Prev” and “Next” to check previous and next tip. You can uncheck “Show daily
tips on start-up” to not open the dialog box each time software is started.

2.10.6 System Info and Registration
You can view software version number, control card and manufacturer information in the software.
Click “Help” → “About”, and a dialog box will pop out as shown in Fig. 2- 57.
Click “Devic”, to see running time and running length of the machine tool to facilitate machine
management and maintenance. “Register” function is used for limiting the system usage time by
registering the control card. The registration code provided by Bodor Electronic Technology Co. Ltd..
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Fig. 2- 57 Dialog Box “About”

2.10.6.1 Register with Registration Code
After getting a registration code, you can register the use time in BodorPro.
When the machine tool is in not machining in idle or E-stop state, you can register according to the
following steps. Do not register when the machine tool is running or in pause. Otherwise, the software
will warn you that “Machining. Unable to execute the operation!”.
Registration steps with registration code are as follows.
1)

Open “About” dialog box, and check the device number. Or you can click on the button “Register…”
to check the device number, as shown in Fig. 2- 63.
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Fig. 2- 63 Check Device Number

2)

Enter the registration code you have got into the input box of “RegCode” as shown in Fig. 2- 63, and
then click “OK”.

3)

The system will prompt “Register successfully. Please restart your computer!” Restart your
computer. After restarting the computer, open BodorPro and check the current registration
information.

Device number changes with registered times, reflected in the last three numbers of device number. When
registered times is 0, the last three numbers are 000; when registered times is 1, the last three numbers 001.
After successful registration, system use time will be limited. When the registered time is to be overdue
or already overdue, the software will prompt different information according to your current state and
remaining hours.


Registration Overdue

If your registration is overdue, register dialog box instead of software interface will pop out when you try
to open the software. And as shown in Fig. 2- 64, it warns you “The software is overdue. Please register!”
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Fig. 2- 64 Registration Overdue

The control card number has been written before you receive it. Please contact with the manufacturer if you failed
to register with the control card. As shown in Fig. 2- 65, error will prompt if you failed to register.

Fig. 2- 65 Board Class Error
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3 Machining Debugging
3.1 I/O Ports Specification
3.1.1
1)
2)

I/O Ports

Select open “System” → “Ports Setting” and you can view input and output signals in “IoPorts”
dialog box. Solid dots represent input signals, while hollow dots represent output signals.
Red dots indicate the signals are invalid at the time (with no input or output), green dots indicate the
signals are valid at the time. The “IoPorts” dialog box is as shown in Fig. 3- 1. (It is for reference only.
Ports displayed in “IoPorts” vary with different software versions and hardware board card types.
The actual situation is in line with shipment).

Fig. 3- 1 IO Ports Interface

3)

Alter the input port polarity in the software in terms of such buttons selected as origin switch and
E-STOP button: the polarity of NO input ports is N; the polarity of NC input ports is P.
To modify port polarities, select the ports to be modified, and then click “ConvertPol”. The password to
modify polarity is “ncstudio”. After finishing modifying, restart BodorPro to make the modification
effective.

3.1.2
1)

Diagnosis of Terminal Board Ports

Electrify the electrical box. At this time, the dots in front of such input signals as zero signals of the
two axes, E-STOP signal and program start/stop signals should be in red, indicating that there are
no inputs. Otherwise, it is necessary to check the correctness of electrical circuitry and signals
polarity. If electrical circuitry is correct, alter the corresponding signal polarity to ensure the dots in
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2)

3)

front of the above-mentioned signals shown in red.
Press the button “Start”, and observe whether the dot color of “program start” signal changes. When
the button is being pressed, the dot color should show in green, and in red after released. If there is
no change to the dot color, check whether the LED on the terminal board works normally when
being pressed. If the terminal board works normally, it indicates that the software has not collected
the signals from the terminal board. Examine the connection between the control card and the
terminal board via DB9M/F. Similar method can be taken to examine program stop signal and
emergency stop signal.
In accordance with the above method, open “IOPort” window and simulate to trigger the zero signals,
observing whether the dot in front of the zero signal turns into green when an origin button is being
triggered. Make sure that both the origin signals of X-axis and Y -axis can be received.

Do not connect the terminal board with any driver when you are diagnosing I/O ports of the terminal board.
Otherwise danger may occur.

3.2 Driver Parameter Setting
3.2.1

Pin Definition of the Servo Driver

The socket of servo driver joint is three-row DB15 holes. Its pins definition is shown in Fig. 3- 2.

Fig. 3- 2 Pin Definition of the Driver

Signal
A+; AB+; BC+; C-

ALM

Definition

Output/Input

Remarks

Feedback signal of Input, differential signal
encoder phase A
transmission mode
Receive the differential output of
Feedback signal of Input, differential signal encoder signal (phase A, B, C) from
encoder phase B
transmission mode
driver frequency divider (equal to
Feedback signal of Input, differential signal RS422).
encoder phase C
Driver alarm signal
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transmission mode
Input

When breakdown occurs in driver,
this output (transistor) switch will be
closed or disconnected.

Signal

Definition

Output/Input

Remarks

SON

Servo ON signal

Output

This signal used for opening (power
on) and closing (power off) servo
motor. When it is connected to
COM-, dynamic brake will be
released and the driver is allowed to
work (servo enabled).

ALM-RST

Driver alarm clear
Output
signal

The alarm state will be cleared
when this signal keeps closed with
COM- for above 120 ms.

PUL+;
PUL-

Pulse output

Output, differential signal
transmission mode

DIR+;
DIR-

Direction output

Output, differential signal
transmission mode

+24V;
GND

DC 24V power

Output

3.2.2

Connected to driver

Parameter Setting for Drivers

Please refer to section 4.7 for parameter setting of WISE, YASKAWA, PANASONIC, FUJI, DELTA servo
drivers.

3.2.3

Parameter Setting for Other Servo Drivers

Note:
1)

Firstly confirm the SON signal type of selected servo driver to see whether it is active low (i.e. servo
is ON when SON and GND of 24V power is conducted);

2)

Then make clear the level of servo driver alarm output port when there is no alarm. If it is normally
low-level, the input port polarity of servo alarm should be “P” in “IOPort” window of software; if it is
low-level when alarm occurs, the port polarity should be “N”; for polarity setting, refer to section
3.1.1;

3)

Make sure the type of pulse signal received in parameters setting of servo driver is “pulse +
direction”; make clear whether there is external emergency stop signal input in the input terminal of
servo driver, and the logic of this signal;

4)

Before the trial run of the driver, 24V power supply must be provided for the terminal board, because
the 24V power for the driver is indirectly provided through the terminal board; if the driver can’t rotate,
make sure the driver parameter “forward and reverse rotation input prohibited” is set invalid.
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3.3 System Parameter Setting
3.3.1

Axis Direction Setting

You should ensure the positive direction of each axis through the standard coordinate system following
right-hand rule, as illustrated in Fig. 3- 3.

Fig. 3- 3 Right-hand rule coordinate system

For a cutting machine, the direction of machine axes is decided by both machine tool type and the layout
of each component. The basic coordinate axes of a machine are X-axis, Y-axis, and Z-axis:
Z-axis: the direction of the cutting head moving away from workpiece is its positive direction (+Z).
X-axis is perpendicular to Z-axis and parallel to the clamped surface of workpiece. For a single column
vertical milling machine, if the user faces the spindle and looks in the column direction, right moving
direction is the positive direction of X-axis (+X).
X-axis, Y-axis and Z-axis together constitute the coordinate system following right-hand rule.
After ensuring the positive direction of each axis based on right-hand rule, you can manually move the
machine through operation panel or the shortcut keys to check whether the direction is correct or not.
Through this process, you can watch and judge whether the direction indicated by manual button and
actual moving direction is consistent.

 Related Parameters
Parameter
Axis direction(X/Y/Z)

Range
1; -1

Default
1

Description
It specifies the feeding direction of X, Y and Z.

You can judge whether the direction indicated by manual button and actual moving direction is
consistent by manually moving the machine. If not (for example, pressing X+ button only to find
machine moves along the negative direction), you can modify the corresponding value. For
example, if the value of parameter “Axis direction” is “1”, you should change it into “-1”.
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3.3.2

Workbench Stroke Setting

After confirming machine origin and moving direction of each axis, set the manufacturer parameters
“Lower & Upper limit of worktable stroke” and “Check worktable stroke” according to the actual size of
machine tool, so as to enable software limit function.

 Related parameters
Parameter

Range

Default

Lower limit of worktable stroke(X)

[-999999, upper limit)

0 mm

Lower limit of worktable stroke(Y)

[-999999, upper limit)

0 mm

Lower limit of worktable stroke(Z)

[-999999, upper limit)

-3000 mm

Lower limit of worktable stroke(W)

[-999999, upper limit)

0 mm

Upper limit of worktable stroke(X)

(lower limit, 999999]

3000 mm

Upper limit of worktable stroke(Y)

(lower limit, 999999]

1500 mm

Upper limit of worktable stroke(Z)

(lower limit, 999999]

1 mm

Upper limit of worktable stroke(W)

(lower limit, 999999]

3000 mm

Check worktable stroke(X/Y/Z/W)

YES; NO

YES

3.3.3

Description
The machine coordinate
of the allowable upper
limit or worktable stroke.
The machine coordinate
of the allowable lower
limit or worktable stroke.
Whether to enable
worktable stroke check.

Pulse Equivalent Setting

Pulse equivalent (p): the moving distance of workbench or rotation degree of rotary axis corresponding
to one pulse sent by CNC device, the minimum available distance controlled by CNC system as well.
The smaller the pulse equivalent is, the higher the machining precision and surface quality will be. The
larger, the faster feedrate will be. Therefore, lower pulse equivalent should be set under the condition of
meeting the demand of feedrate. The relationship between maximal feedrate and pulse equivalent is as
follows.
Max. Feedrate= pulse equivalent X 60 X frequency
For example, the hardware frequency of Lambda 4S is 1 MHz and provided the pulse equivalent is 0.001
mm/p, then:
Max. Feedrate=0.001 X 60 X 1000000= 60 m/min
Mechanical deceleration ratio (m/n): the ratio of reducer input speed to output speed, equal to the
ratio of the teeth number of driven wheel to that of driving wheel. When applied in CNC machines, it
specifies the ratio of motor speed to screw speed.
Mechanical deceleration ratio 

reducer input speed
reducer output speed



teeth number of driven wheel
teeth number of driving wheel



motor speed
screw speed

Pitch (d): The axial distance between the corresponding points of two adjacent teeth on the threads.
The calculation of pulse equivalent varies with different motor systems.
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Stepping Motor

In general, firstly set the subdivision and then calculate the pulse equivalent. You can set the pulse
equivalent before calculating subdivision. Their relationship can be shown as:
d
360
m

x
p

n

Hereinto, p stands for pulse equivalent, x represents subdivision of stepping motor while θ stands for
stepping angle. Therefore,
Pulse equivalent 

screw pitch

360
 subdivision  mechanical deceleration ratio
stepping angle

For instance, the selected screw lead of X-axis for a certain type of machine tool is 5 mm, and the
stepping angle of stepping motor is 1.8 degree, with “10” subdivision and motor directly connected with
screw by coupling. Thus, the pulse equivalent of X-axis is:
Pulse equivalent 

5mm

360
 10  1
1.8

 0.0025mm / p

 Servo Motor
In general, set the default value of pulse equivalent as 0.001 mm/p and calculate electronic gear ratio
(B/A). Their relationship can be shown as:
Electronic gear ratio

B encoder resolution

 mechanical deceleration ratio
screw pitch
A
pulse equivalent

B Fp m


A
d
n
Electronic gear ratio (B/A): the parameter of servo driver (take YASKAWA driver as an example, B is
PN202 while A PN203). This ratio represents servo scales up or down the pulse frequency sent by CNC
system. When B is larger than A, it means scaling up and vice versa. For example, provided the pulse
frequency sent by CNC system is 100 HZ, if the numerator of electronic gear ratio (B) is set as 1 while
the denominator 2, the actual running speed of servo is 50 HZ. On the contrary, if the numerator is set as
2 while denominator 1, the actual running speed turns to 200 HZ.
Encoder Resolution (F): needed pulse number for one circle of servo motor. Please see the servo
motor label plate and then refer to the corresponding manual to confirm its encoder resolution. A label
plate of YASKAWA SGMSH type motor is as follows, and the 4th character in motor type is the serial
encoder specification, so the resolution of this motor is 217, i.e. 131072.
Namely,
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Fig. 3- 4 Name Plate of Servo Motor-encoder Resolution

For instance: (an example of YASKAWA servo) screw pitch of a certain type of machine is 5 mm, with 17
bit encoder resolution, “0.0001 mm/p” pulse equivalent and “1:1” deceleration ratio.
Electronic gear ratio 



PN202
PN203



217
8192
1 
5 / 0.0001
3125

Rotary Axis

The pulse equivalent of rotary axis refers to the rotation degree of the axis clamping the workpiece
corresponding to each pulse. The difference of rotary axis movement from linear axis movement lies in
that the screw pitch of rotary axis is 360 degrees. Therefore, in calculating rotary axis pulse equivalent,
you just need to replace screw pitch with 360.


For Stepping Motor
Pulse equivalent 



360

360
 subdivision  mechanical deceleration ratio
stepping angle

For Servo Motor
Electronic gear ratio

B encoder resolution  pulse equivalent

 mechanical deceleration ratio
A
360

 Related Parameters
Parameter

Range

Default

Pulse equivalent(X/Y)

[1E-08,1000] mm/p

0.002

Pulse equivalent(Z)

[1E-08,1000] mm/p

0.001

Description
It refers to the displacement or
angle generated on the relative
feed axis per control pulse.

The setting value of pulse equivalent must match that of the electronic gear ratio of servo driver or that of
subdivision of stepping driver.
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3.3.4


Return to the Machine Origin (Homing)

Detect Y1Y2 origin error

In ideal condition, the connecting line between Y1 axis origin and Y2 axis origin should parallel to X-axis.
During actual machining, the line may not parallel to X-axis because of inherent errors and machine
collision. Therefore, before returning to machine origin, you need to “detect 2Y error” to record the
position error between machine origins of Y1 and Y2 axis. The system will correct the error during
returning to machine origin process.
Steps of detecting 2Y origin error:
1) Make the connecting line between encoders of Y1 axis and Y2 axis perpendicular to guides;
2) Execute 2Y origin error detection. Click “Mach” → “Go Home” → “Detect 2Y Origin”. And the
system will measure and record the position error between machine origins of Y1 and Y2 axis;
3) Execute homing. The system will offset the recorded error during Y axis returns to machine
origin.


Return to the machine origin(Homing)

Homing is a procedure to synchronize local coordinate system with actual external coordinate system
via control system. Specifically, since the concrete position of each axis is not detected in the system,
after system start-up, it will control the motion of each axis and detect the switch signal pre-installed on
each axis during the motion (the control system has already known the installation position of these
switches). Thus, once these switch signals are found, the system will acquire pre-specified position of
the machine tool and then set the coordinate of this position as current coordinate, namely, the local
coordinate system is synchronous with the actual one.
Coarse positioning is used to drive X/Y axis around the machine origin. And the following switches can
be adopted in coarse positioning, involving proximity switch, mechanical switch, photoelectric switch, etc.
Due to the limit of these switches on precision and repetition in positioning, the X/Y axis is unable to
return to machine origin exactly in coarse positioning, thus, fine positioning is compulsory.
Fine positioning, with various methods, is used to make each axis return to machine origin exactly by
regarding encoder origin as fine positioning switch, i.e. the axis is searching for machine origin in the
motion via detecting encoder origin. Due to one origin signal sent per revolution of encoder, fine
positioning signal is periodic.
Set manufacturer parameter “Bkref” in the software according to the installation positions of zero
sensors of the two axes. When the setting is correct, run “Go Home” under “Mach” menu.
When software is started, dialog box as shown in Fig. 3- 5 will pop up, prompting returning to the
machine origin. When item “The dialog pops up automatically when the software is started.” is checked,
the dialog box will automatically pop up each time the software is started; otherwise, you need to click
sub-menu item “Go Home  Go home settting” under “Mach” menu to open the dialog box.
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Fig. 3- 5 Go Home



All axes or single axis go home

When “ all axes” or single axis(X Axis, Y Axis or Z Axis) is clicked, the system will eject a dialog box to
confirm whether to go home. When going home is confirmed, the mark

will appear before

corresponding axis.


Set directly

If you can ensure that the machine coordinate of the current position is same as the actual machine
coordinate of the machine tool, i.e., the machine tool has not been turned off and abnormal situations
such as E-stop has not happened, you can set current machine coordinates as correct and accurate by
clicking “Set Directly”. When this operation is completed, the homing mark “

” appears before

corresponding axes in machine control bar.

Only after homing can functions such as software limit, returning to fixed point be enabled.
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 Related Parameters
Parameter

Default

Description

Force;
Force homing before Yes:
No: Not force
machining

NO

In case of E-stop or power failure during
machining, after restart, directly continuing
machining may cause deviation, while resuming
machining after homing to retrieve workpiece
coordinate system will ensure machining
accuracy.

Used;
Limit switch used as Yes:
No: Not used
home switch

YES

Whether the limit switch can be used as home
switch as well.

-1

The moving direction of X/Y axis in coarse
positioning stage during the process of backing
to the reference point.

1

The moving direction of Z axis in coarse
positioning stage during the process of backing
to the reference point.

6000

The feeding speed of X/Y axis in coarse
positioning stage during the process of backing
to the reference point.

1800

The feeding speed of Z axis in coarse
positioning stage during the process of backing
to the reference point.

600

The feeding speed of X/Y axis in precsion
positioning stage during the process of backing
to the reference point.

60

The feeding speed of Z axis in precsion
positioning stage during the process of backing
to the reference point.

X/Y
direction
in
coarse positioning

Range

1: Positive; -1:
Negative

Z direction in coarse 1: Positive; -1:
Negative
positioning
X/Y speed in coarse
[0.06, 9000]
positioning
Z speed in coarse
[0.06, 9000]
positioning
X/Y
speed
in
precision positioning

[0.06, 6000]

Z speed in precision
[0.06, 6000]
positioning

Back space of X/Y/Z

[-100, 1000]

2

The additional displacement of X/Y/Z after fine
positioning during the process of backing to the
reference point; plus value indicates positive
direction while minus value negative direction. If
its value is “0”, the axis will not move.

2Y Error Bound

[0, 10000]

2

The allowable difference range between the
encoder origins of dual Y axes.
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3.4 Speed Parameter Setting
3.4.1

Single Axis Machining Acceleration

It is used to describe the acceleration / deceleration ability of a single axis, with unit mm/s2. The value is
determined by the physical characteristic of machine tool, such as quality of movement part, torque,
resistance, cutting load of feed-motor, and so on. The larger the value is, the less time spent in the
process of acceleration / deceleration will be, and the higher the efficiency will be. Set the value smaller
at the beginning; make the machine tool perform various typical movements for a period of time, and
carefully observe it; if there is no abnormal situation, increase the value gradually; otherwise, decrease
the value and reserve 50%~100% insurance allowance.

3.4.2

Cornering Acceleration

It is used to describe the acceleration/deceleration ability in synchronized motion of multi-feed-axis, with
unit mm/s2. The value limits the maximum speed of machine tool in circular movement. The larger this
value is, the higher the maximum allowable speed on circular movement of machine tool will be.
Generally, for servo motor systems, the value is between 1000 and 5000; for heavy machine tools, the
value should be smaller. Set the value smaller at the beginning; make the machine tool perform various
typical movements for a period of time, and carefully observe it; if there is no abnormal situation,
increase the value gradually; otherwise, decrease the value and reserve 50%~100% insurance
allowance.

3.4.3

Maximal Velocity of Reference Circle

Maximal velocity of reference circle corresponds to arc velocity limit function. When a machine tool
processes an arc, it will vibrate due to centripetal force. To reduce this kind of vibration, the software
limits machining speed during machining an arc in terms of centripetal acceleration. Take default setting
as an example, the maximal line velocity of the reference circle (Diameter: 10 mm) is 1800 mm/min.
The formula to calculate centripetal acceleration is as follows.

a

v2
r

Among the formula, r  (10 / 2)mm ; v  1800mm / min .
Thus centripetal acceleration a can be calculated; when other arcs are processed, this centripetal
acceleration is the maximum allowable centripetal acceleration. Arc velocity will be limited, if it is too
large causing centripetal acceleration larger than a calculated in this formula.
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3.5 Compensation Parameter Setting
3.5.1

Causes for Screw Error Compensation

Screw error consists of screw pitch error and errors caused by backlash. Generally, these two errors
don’t need compensation, but backlash compensation is needed in high precision required situation, if
higher precision is required, both the two compensations are needed.


Pitch compensation:

Pitch error is caused by defect in manufacturing of screw and long-term wear, etc. In order to improve
precision, pitch compensation is needed. The sketch of screw is shown in Fig. 3- 6(A). Coordinate
system is established, based on “0” point on the screw as the reference point, nominal value as
X-coordinate, and actual value as Y-coordinate. Then ideal moving curve is as curve “1” in Fig. 3- 6(B),
however, actual curve will be curve “2” due to pitch error. That is to say, the Actual value is not the same
as its corresponding Nominal value, actual moving curve deviating from the ideal one, and their
difference is called error, i.e.:
Error = nominal mechanical coordinate – actual mechanical coordinate

Fig. 3- 6 Analysis of Pitch Error



Backlash compensation:

Hysteresis feature is caused by forward and reverse clearance. Assuming that CW rotation of driving
shaft is negative motion, leading the driven shaft to counter motion, servo motor will be idling without
moving worktable because of mechanical driving chain backlash when the driving shaft suddenly begins
CCW rotation (positive motion). After staying at a certain position for some time, worktable will move
along the negative direction with the driving shaft; when the direction of the driving shaft changes again,
the situation is the same, which is called Hysteresis. If there were no pitch error under ideal condition,
the moving curve of worktable is shown in Fig. 3- 7(A), and the curve of horizontal section is during the
idling of servo motor without worktable movement. The actual moving curve of worktable is shown in Fig.
3- 7(B).
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Fig. 3- 7 Analysis of Backlash

The popular explanation is: because the slider is generally fixed on the screw whose outer wire and the
inner wire on the outer wire cannot be completely matched, backlash compensation compensates the
clearance between the screw of last direction that the slider needs to finish after reversing its direction.

3.5.2

Screw Error Compensation Method

When Parameter “Lead screw compensation mode is set as “2”, screw error compensation function will
be enabled; otherwise, the function will be disabled. With this function, the system will compensate both
screw error and backlash error together.
After you list the forward and backward errors of nominal coordinate on each axis in the screw error
compensation file, the system will compensate automatically according to the data you have listed.


Screw error compensation file

The name of lead screw error compensation file is axeserr.dat, which can be found under folder Data of
installation directory (C:\Program Files\Bodor\BodorPro\config). Modification to the data in the lead
screw error compensation file will become valid after the software is restarted.
The file format is:
1)

Firstly specify the number of axes to be compensated, for example, <Compensation Count = “3”>
represents that 3 axes are to be compensated.

2)

Then specify error sequence of each axis. To work properly, the contents in this sequence must be
arranged in the ascending order of position value from small to large, as follows.

[Axis.<Axis Name>]
<Position>, <Forward Error>, <Backward Error>
<Position>, <Forward Error>, <Backward Error>
<Position>, <Forward Error>, <Backward Error>
Among them, <Axis Name> is X, Y, Y2… (Case-insensitive)
Position: nominal value, i.e. the theoretically arrived position driven by the pulses sent by the system
when there is no compensation;
Measured Value (P): the actually arrived position driven by the pluses sent by the system to move
forward when there is no compensation.
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Measured Value (N): the actually arrived position driven by the pulses sent by the system to move
reversely when there is no compensation.


Lead Screw Error Compensation Tool

Click “Screw-Err Compensation Guide” under “Mach” menu to eject the main interface of
AxesErrEditor.exe as shown in Fig. 3- 8.

Fig. 3- 8 Screw Error Compensation Guide

As above, click “LoadTools” at bottom to eject “AxesErrEditor” interface as Fig. 3- 9.

Fig. 3- 9 Main Interface of AxesErrEditor.exe
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Generally the value of lead screw error compensation can be measured by a laser interferometer, with
two ways for compensation.
1)

File compensation. Select “Import File” under “File” menu, choose the compensation data recorded
by a laser interferometer to be imported in the pop-up dialog, and then save the data file to
corresponding configuration folder. In this way, automatic compensation will be performed during
machining in terms of the data in the file. Currently, only .lin and .rtl format files are supported.

2)

Directly set compensation on the interface. Enter position, positive measured value and negative
measured value in the interface, positive error, reverse error and reverse clearance calculated
automatically. Then save the data file under the corresponding configuration folder. In this way,
automatic compensation will be performed during machining according to the value in the file.

A visualized path graph, as shown in Fig. 3- 10, will be generated according to the input data.

Fig. 3- 10 Lead Screw Error Compensation Generation Interface

In the above picture, the red line indicates the path of positive motion; the blue line the path of reverse
motion; the middle gray line the ideal path.
Currently, this tool can save the lead screw error compensation file as two versions: V9 and V12, which
can be switched under “Settings” menu. The figure above shows the interface under V12 version.
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You should note the following 3 points during screw error compensation of Y axis or Y2 axis.
1)

When you import the screw error compensation parameters with the load tool, you need to select whether the
imported data is for Y axis or Y2 axis.

2)

If you directly enter the screw error compensation data in the load tool, you need to select the relevant
interface for Y axis or Y2 axis.

3)

If you enter directly the compensation data for Y2 axis in file axeserr.dat, the value of compensation data
must be the result of 1+actual axis number. The compensation data in file axeserr.dat is shown as Fig. 3- 11.

Fig. 3- 11 Compensation Data for Y2 Axis

3.5.3

Effect of Screw Error Compensation

Composed of unidirectional error correction, traditional compensation adds backlash compensation
simultaneously in reverse motion to improve moving precision. Although this kind of compensation can
improve the control precision of a semi-closed machine tool to some extent, the precision after
compensation of a point which is located precisely before compensation cannot be ensured according to
experiments.
Bodor control system realizes bidirectional screw pitch error compensation and can confirm the
correction of forward and backward direction by one measure of machine tool precision, which greatly
reduce work load of machine tool measurement and improve positioning accuracy, while for traditional
compensation, backlash value and screw pitch error value are measured separately with compensation
table made afterwards.
It has been found that lead screw error compensation greatly improves positioning accuracy and
repeated positioning accuracy of CNC machine tools.

 Related parameters
Parameter

Range

Default

0: No compensation;
Lead screw compensation
1: Backlash compensation;
mode
2: Screw error compensation

0

Backlash X/Y

0
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[0, 0.1] mm

3.6 Machine Setup Detection
3.6.1

Check Electronic Gear Ratio and Pulse Equivalent

To examine whether the value of electronic gear ratio matches with that of pulse equivalent, make a
mark on any axis of the machine tool and set this marked point as the workpiece origin in the software.
Drive this marked axis to move a fixed distance by direct command input, jog or handwheel, and so on.
Measure the actual moving distance with a vernier caliper and compare whether the measured result is
equal to the distance shown in the software.

3.6.2

Examine If Any Pulse Is Lost

Direct method: mark a little dot on the surface of a workpiece blank with laser; set this point as the
workpiece origin; repeatedly move the two axes; and then back to the workpiece origin; mark a little dot
again with laser to observe whether this dot completely coincides with the marked dot.
For servo systems, there is a more precise method: set servo driver mode as “input pulse count
mode“ of the “surveillance mode“ (for example, the parameter of YASKAWA servo is UN00C); regulate
the servo driver to display the lower 4 bits (with “L ” before the count value ) in count value (hexadecimal
system); set workpiece origin and then write down the pulse count value at this time, then repeatedly run
a procedure with laser off, then back to workpiece origin and see whether the pulse count value at this
time is the same with the original value. For YASKAWA servo, as long as the value difference of pulse
count value is no more than 4 (the frequency of host controller is 1/4 times the frequency of pulse sent by
servo drive), indicating that the main controller sends pulses within the tolerance of 1 pulse, the control
system runs normally; otherwise, please check the pulse signal type of servo driver, and make the pulse
type received by servo in accordance with the pulse type sent by the card.

3.6.3

Laser Technic Detection

Laser technic detection is mainly to examine whether the state of such ports as laser, blow, follow, Z-up
changes with the actual situations, and whether parameters of laser technic in “Layer Parameters”
dialogue box are appropriate, like time sequence and delay of follow, blow and laser, and whether
voltage change of the laser power control port AVC correlates with laser power change.

3.7 Set Workpiece Origin
Workpiece origin refers to the zero position of workpiece coordinate. Before machining, its actual
position should be confirmed. The steps are as follows.
1)
2)

Manually click X axis or Y axis buttons in machine control bar to move the corresponding axis to the
target position;
Click “Set WorkOrg” sub-menu under “Mach” menu, or click “Set Origin” button in machining control
area, or just press F5 directly to set the current position as the workpiece origin.
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Besides, the system also supports to set the berth point as workpiece origin. Select
toolbar or select “Mach” → “Set origin position”,

on drawing

a dialog box as shown in Fig. 3- 12 will pop up. After

“Auto apply berth point” is checked, you can directly execute “Set WorkOrg” in machine control area
without selecting workpiece origin each time a new file is loaded since the system takes the feature point
of the object as workpiece origin by default.

Fig. 3- 12 Set Workpiece Origin

Also you can click “Set by mouse” to catch the workpiece origin and the system enables the catch
support function automatically so that you can locate the position wherever they prefer.

3.8 Simulate
You can enable frame check function by clicking the button, or pressing F7 directly, or
selecting “Mach” → “Mach Control” → “Frame”. The system will move around along
the circumscribed rectangle of machining file to decide the machining range.
When a program is loaded and the system is in idle state, you can enable simulation by
clicking the button or pressing F8 directly, or selecting “Mach” → “Mach Control” →
“Simulation”. The system will start rapid simulation from the first line of program
automatically. In simulation mode, the system does not drive the machine tool to do
mechanical and electrical movement, but machining path will be shown at high-speed.
You can enable dry run by clicking the button, or selecting “Mach” → “Mach Control”
→ “Dry Run”. In dry run mode, the machining program is machined as in real
machining , but the ports are not turned on.

3.9 Machining Control
You can start machining process by clicking the button(disabled when machining files
are not saved or Estop alarm exists), or selecting “Mach” → “Mach Control” → “Start”,
or pressing F9 directly. The system will begin machining automatically from the first line
of the machining file.
You can stop machining process by clicking the button, or selecting “Mach” → “Mach
Control” → “Stop”, or just pressing F11 directly. The system will end the machining and
then enters into idle state.
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You can The system will resume machining from interrupted position automatically by
clicking the button or selecting “Mach” → “Mach Control” → “Breakpoint Resume”, or
press Shift and F9 simultaneously.

1)

If parameter “Force Homing before Machining” is set to “YES”, and there is no homing mark, button ‘Start’
is disabled.

2)

The software saves machining info every 5 seconds. If power failure occurs before the software saves the
machining info next time, after re-powered, the software will return to the last saved position after this
function is used, i.e. the machine tool will retract a little distance before continuing machining.

3)

When the accuracy of workpiece coordinate is ensured, you can make the machine tool rapidly resume
machining from breakpoint at machining stop, power failure or E-stop. Otherwise, you need to home all axes
before executing breakpoint resume.

3.10 PWM (Pulse-Width Modulation)
3.10.1 Pulse Modulation Signals
Multiple pulse modulation signals are provided for compatibility with various lasers.
1)

+24 V single-ended signal: MOD (24 V) & COM for outputting +24 V single-ended signal.

2)

+5 V single-ended signal: MOD (5 V) & COM for outputting +5 V single-ended signal.

3)

±5 V differential signal: MOD (5 V) & /MOD (5 V) for outputting ±5 V differential signal.

3.10.2 Frequency and Duty Cycle
Frequency and duty cycle can be set as required.
Enter the layer parameters dialog box, and then click “General parameters” and select “Duty cycle” in the
“Adjust power mode” under laser device parameters.
Frequency should be within 0~100000 Hz, while duty cycle within 0%~100%.

3.11Analog Adjustment
Click “Analog Adjust” under “Mach” menu, and a dialog box as Fig. 3- 13 will pop out.
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Fig. 3- 13 Dialog Box “Analog Adjust”

You can drag sliders of “Laser Power”, “Pressure”, “Analog1” and “Analog2” to adjust the items.
You can click “Laser”, “Blow”, “Follow” and “Z UP” to open or close corresponding ports.
After checking “JOG”, click the four buttons on the right to output in jog mode; otherwise, output will be
continuous.

3.12 RS232 Communication
RS-232-C is the standard for serial communication jointly made by EIA, AT&T (Bell System), modem
manufacturers and computer terminal manufacturers, which is suitable for communication with transfer
rate within the range of 0~20000 b/s and generally adopted by communication within 20 m.
V12 fiber laser cutting software can realize its communication with a laser and follow-up apparatus via
RS232 sending and receiving instructions.


Wiring specification

Connect the RS232 port on a laser to the RS232 LASER on the terminal board EX30A via a DB9 cable
to read laser power.
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4 Appendix
4.1 Wiring Diagrams of Ports
4.1.1

Vertical Screen Configuration

Connected to
NC65A/65B/65C
PM85A/95A
Connected to
X-axis driver
Connected to
Y1-axis driver
+24V Power
Connected to
Y2-axis driver

Active High/Low
X-axis Positive Limit
X-axis Negative Limit
Y-axis Positive Limit
Y-axis Negative Limit
Z-axis Positive Limit
Z-axis Negative Limit
Estop
X-axis Zero
Y1-axis Zero
Y2-axis Zero
Z-axis Zero

Connected to
Z-axis driver

Connected to MPG

Analog Output
Common

Upper Workbench Stop Pos
Lower Workbench Stop Pos
Inverter Alarm
Oxygen Pressure Alarm
Nitrogen Pressure Alarm
Lubrication Alarm
Chiller Alarm
Laser Device Alarm

Common
Common
Laser
Common
Lead Light(Lead)
IPG ON(Emmision)
Common
Red Lamp
Green Lamp
Yellow Lamp

Open the cover, and connect to
extended terminal board EX30A5

Fig. 4- 1 Wiring of Lambda Controller in Vertical Screen Configuration Laser Cutting
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To connect Lambda 5S Controller

+5V Single-ended
Modulation Signal
+24V Single-ended
Modulation Signal
+5V Differential
Modulation Signal
Analog Output 1

Analog Output 1

COM
MOD(24V)
COM
MOD(+)

+24V

MOD(-)

COM

AV01

AVI1

COM

AVI2

+3.3V

Analog Output 1

MOD(5V)

AV02
COM

+24V Power

AVI3
AVI4

AV03

ACOM

COM

Active High/Low
W-axis Positive Limit
W-axis Negative Limit
W-axis Zero

S
X00

X00
X01
X02
X03

X01
X02
X03
X04

X04
X05
X06
X07
COM

SENSOR

Y07

Y07

Y06

Y06

Y05

Y05
COM

RS232

Y04

To connect external
laser device

Y04

COM

Y03

Y03

Y02

Y02

X07
SYSTEM

Y01
COM

Y01

Y00

X06

Y00

Common
Air/Oxygen Valve
Nitrogen Valve
Common
Motor CW(LowerIn)
Motor CCW(UpperIn)
Common
Lubrication Pump ON
Fan ON(Exhaust)
Common
Board Support
Machine Bed Clamp Valve

X05

3

2

4

1

To connect
capacitance sensor

Connect to EX31A1

Fig. 4- 2 Wiring of Extended Terminal Board EX30A5 in Vertical Screen Configuration Laser Cutting

The outputs of terminal board EX30A5 are Darlington outputs, and their load current should be ≦ 0.4A.
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Connect to EX30A5

C01
Y03
Y04
Y05

Common

C02
Y06

Common

C03
Y07

Common
Common

C04
Y08
C05
Y09

S00
X00

Y02

X01

Y05

X00
X01
X02
X03

C02
Y06

X04
X05
X06
X07

C03
Y07

X08
X09

Y04

+24V

COM

Y01
C01
Y03

POWER

Y02

Common

Y00 Y01 Y02 Y03 Y04 Y05 Y06 Y07 Y08 Y09

Y01

C00
Y00

SYSTEM

C00
Y00

+3.3V

Common

X02

+24V Power
Active High/Low
Exchange Workbench
Release Machine Bed
Machine Bed Released

X03
S01
X04
X05
X06
X07

C04
Y08

S02
X08

Workbench Jog Forward (LowerIn)

C05

S03
X09

Workbench Jog Forward (UpperIn)

Y09

Fig. 4- 3 Wiring of Extended Terminal Board EX31A1 in Vertical Screen Configuration Laser Cutting
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4.1.2

Tube cutting configuration

Connected to
NC65A/65B/65C
PM85A/95A
Connected to
X-axis driver
Connected to
Y-axis driver
+24V Power
Active High/Low
X-axis Positive Limit
X-axis Negative Limit

Connected to
Z-axis driver

Z-axis Positive Limit

Connected to
W-axis driver

Estop
X-axis Zero
Z-axis Zero
W1-axis Zero

Connected to MPG

W2-axis Zero
Y-axis Positive Limit
Y-axis Negative Limit
Y-axis Zero

Analog Output
Common
Tube Support 1
Common
Tube Support 2
Common
Laser
Common
Lead Light(Lead)
IPG ON(Emission)
Common
Red Lamp
Green Lamp
Yellow Lamp

Oxygen Pressure Switch
Nitrogen Pressure Switch
Lubrication Alarm
Chiller Alarm
Laser Device Alarm

Open the cover, and connect to
extended terminal board EX30A5

Fig. 4- 4 Wiring of Lambda Controller in Tube Configuration Laser Cutting
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To connect Lambda 5S Controller

+5V Single-ended
Modulation Signal
+24V Single-ended
Modulation Signal
+5V Differential
Modulation Signal
Analog Output 1

Analog Output 1

COM
MOD(24V)
COM
MOD(+)

+24V

MOD(-)

COM

AV01

AVI1

COM
AV02
COM

+24V Power

AVI2

+3.3V

Analog Output 1

MOD(5V)

AVI3
AVI4

AV03

ACOM

COM

Active High/Low

S
X00

X00
X01
X02
X03

X01
X02
X03
X04

X04
X05
X06
X07
COM

Y04

SENSOR

Y07

Y07

Y06

Y06

Y05

Y05
COM

RS232

COM

To connect external
laser device

Y04

Common
Lubrication Pump ON
Fan ON(Exhaust)
Common

Y03

Y03

Y02

Y02

X07
SYSTEM

Y01
COM

Y01

Y00

X06

Y00

Common
Air/Oxygen Valve
Nitrogen Valve
Common

Tube support 1 restore position
Tube support 2 restore position

X05

3

2

4

1

To connect
capacitance sensor

Connect to EX31A1

Fig. 4- 5 Wiring of Extended Terminal Board EX30A5 in Tube Configuration Laser Cutting

Machining Debugging「97」

Connect to EX30A5

Common

C01
Y03

Front Chuck Clamped
Front Chuck Released
Common
Back Chuck Clamped Vertically
Common
Back Chuck Released Vertically
Common
Back Chuck Clamped Horizontally
Common
Back Chuck Released Horizontally

Y04
Y05
C02
Y06
C03
Y07
C04
Y08
C05
Y09

POWER

Y02

Y00 Y01 Y02 Y03 Y04 Y05 Y06 Y07 Y08 Y09

Y01

C00
Y00

SYSTEM

C00
Y00

+3.3V

Common

Active High/Low

S00
X00

Y02

X01

Y05

X00
X01
X02
X03

C02
Y06

X04
X05
X06
X07

C03
Y07

X08
X09

Y04

+24V Power

COM

Y01
C01
Y03

+24V

X02
X03
S01
X04
X05
X06
X07

C04
Y08

S02
X08

C05

S03
X09

Y09

Fig. 4- 6 Wiring of Extended Terminal Board EX31A1 in Tube Configuration Laser Cutting

4.2 Dimensional Drawings
255

5

5

265

2-Φ4.5

Fig. 4- 7 Dimensional drawing of Lambda 5S controller
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35.5

122
137

112

4
1.5

63.28

37

45

118

C00
Y00

Y01

Y02

C01
Y03

Y04

Y05

C02
Y06

C03
Y07

C04
Y08

C05

Y09

Y01
Y02
C01
Y03
Y04
Y05
C02
Y06
C03
Y07
C04
Y08
C05
Y09

Y00 Y01 Y02 Y03 Y04 Y05 Y06 Y07 Y08 Y09

C00
Y00

39
X08
X09

X04
X05
X06
X07

X00
X01
X02
X03

+3.3V

S03

Y01

Y05

Y04

Y06

Y07

Y05

Y06

Y04

COM

Y03

COM

Y02

Y03

Y02

COM

Y01

X09

Y00

COM

COM

AV03

COM

AV02

COM

AV01

Y00

X08

S02

X07

X06

X05

X04

S01

X03

X02

X01

X00

S00

COM

+24V

MOD(-)

MOD(+)

COM

MOD(24V)

COM

MOD(5V)
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X04
X05
X06
X07

X00
X01
X02
X03

X07

X06

X05

X04

X03

X02

X01

X00

S

ACOM

AVI4

AVI3

AVI2

AVI1

COM

+24V

2
1

4

RS232
3

195
56.5

SENSOR

SYSTEM

+3.3V

Y07

Fig. 4- 8 Dimensional drawing of terminal board EX30A5

153
56.45

POWER

SYSTEM

Fig. 4- 9 Dimensional drawing of terminal board EX31A1

4-M3

31

30

Fig. 4- 10 Dimensional drawing of pre-amplifier

Machining Debugging「99」

150.9

59.7

PM85A

Fig. 4- 11 Dimensional drawing of control card PM85A

4.3 Wireless Remote Control Handle
The system supports remote control of wireless remote control handle. In spacious areas, it can be
replaced anywhere within 40 meters, freeing you from computers, facilitating machine positioning and
improving operation efficiency and material usage rate.

Fig. 4- 12 Wireless Remote Control Handle
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Introduction of part of the buttons
E-stop

Start

Pause

Stop

Breakpoint resume

Set workpiece origin

Return to workpiece origin

Switch button of jog and rapid jog

Not defined yet

Not defined yet

Positive direction of Z-axis

Negative direction of Z-axis

Positive direction of Y-axis

Negative direction of Y-axis

Positive direction of X-axis

Negative direction of X-axis

Backward

Forward

Mode switch button of Jog and Step
mode

Emission

Lead Light

Auxiliary button, used with

and then press

.

1)

Combination keys for calibration function: turn on calibration switch, press

.

2)

Combination keys for manual high-speed: in manual mode, press



Advantages



With light and concise panel and custom buttons, it can be used to control backing to workpiece
origin, breakpoint resume, and the opening of ports including follow and blow ports.



Without power switch, it adopts low energy cost design and enters power saving mode if no
operation is input in short time.



Signal receiver is installed outside, to improve the stability of signal transmission;



Its rubber protecting coat ensures the durability of the wireless control handle.

and any other direction key.
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4.4 Parameter List
Click “System” → “System Parameters”, and system parameter window will pop out. Below is an
overview of all parameters in vertical screen configuration.
Parameter

Range

Default

Effecting

1.0 Manu
N01

[1, Min. value of max. speed of all axes] mm/min 18000
Immediately
Rapid jogging
The speed in rapid jogging speed. When this value is lower than jogging
speed
speed, the system will set the jogging speed as it.

N02

Jogging speed

[0.06, Rapid jogging speed] mm/min

6000

Immediately

N03

Stepping
speed

[0.06, Min. value of all max. speeds of each
6000
axis] mm/min

Immediately

0

Immediately

0

Immediately

NO

Immediately

1.1 FixedPoint
N04

X
machine
coordinate

[-99999, 99999] mm

N05

Y
machine
coordinate

[-99999, 99999] mm

X-axis machine coordinate of the fixed position.
Y-axis machine coordinate of the fixed position.

1.2 Bkref
Yes: Force; No: Not force

Our system, when used on an incremental machine tool with servo
system, only knows current position with respect to previous position. To
make any position on the machine tool a fixed coordinate, it is necessary
to select a reference point, which is machine origin in our system. In case
of E-stop or power failure during machining, after restart, directly
continuing machining may cause deviation, while resuming machining
after homing to retrieve workpiece coordinate system will ensure
machining accuracy.

N06

Force homing
before
machining

N07

Limit
switch
used as home
switch

1: Positive; -1: Negative

N08

X direction in
coarse
positioning

1: Positive; -1: Negative

N09

Y direction in
coarse
positioning

1: Positive; -1: Negative

N10

Z direction in
coarse
positioning

Yes: Used; No: Not used

YES

Immediately

Whether the limit switch can be used as home switch as well. That is,
exclusive home switch can be absent, and limit switch signal serves as
home switch signal in homing.
-1

Immediately

The moving direction of X axis in coarse positioning stage during the
process of backing to the reference point.
-1

Immediately

The moving direction of Y axis in coarse positioning stage during the
process of backing to the reference point.
1

Immediately

The moving direction of Z axis in coarse positioning stage during the
process of backing to the reference point.
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Parameter

Range
in

N11

X speed
coarse
positioning

in

N12

Y speed
coarse
positioning

in

N13

Z speed
coarse
positioning

in

N14

X speed
precision
positioning

in

N15

Y speed
precision
positioning

in

N16

Z speed
precision
positioning

[0.06, 9000] mm/min

[0.06, 9000] mm/min

Immediately

6000

Immediately

The feeding speed of Y axis in coarse positioning stage during the
process of backing to the reference point.
[0.06, 9000] mm/min

1800

Immediately

The feeding speed of Z axis in coarse positioning stage during the
process of backing to the reference point.
[0.06, 9000] mm/min

600

Immediately

The feeding speed of X axis in fine positioning stage during the process of
backing to the reference point.
[0.06, 9000] mm/min

600

Immediately

The feeding speed of Y axis in fine positioning stage during the process of
backing to the reference point.
[0.06~6000] mm/min

60

Immediately

The feeding speed of Z axis in fine positioning stage during the process of
backing to the reference point.

Back space of
X

Back space of
Y

2

Immediately

The additional displacement of X after fine positioning during the process
of backing to the reference point; plus value indicates positive direction
while minus value negative direction. If its value is “0”, X axis will not
move.
[-100, 1000] mm

N18

6000

Effecting

The feeding speed of X axis in coarse positioning stage during the
process of backing to the reference point.

[-100, 1000] mm
N17

Default

2

Immediately

The additional displacement of Y after fine positioning during the process
of backing to the reference point; plus value indicates positive direction
while minus value negative direction.
[-100, 1000] mm

2

Immediately

N19

Back space of
Z

The additional displacement of Z after fine positioning during the process
of backing to the reference point; plus value indicates positive direction
while minus value negative direction.
1: positive; -1: negative

N20

W direction in
coarse
positioning
in

[0.06, 6000] mm/min

N21

W speed
coarse
positioning
W speed
precise
positioning

in

N22

-1

Immediately

The moving direction of W-axis in coarse positioning stage when backing
to reference point.
600

Immediately

The feeding speed of W in coarse positioning stage when backing to the
reference point.
[0.06, 6000] mm/min

60

Immediately

The feeding speed of W in precise positioning stage when backing to the
reference point.
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Parameter

Range

N23

Back space of
W

N24

2Y
Bound

Error

[-100, 1000] mm

Default
2

Effecting
Immediately

The additional displacement of W after precise positioning when backing
to the reference point.
[0, 10000] mm

2

Immediately

The allowable difference range between the encoder origins of dual Y
axes.

2.0 XAxisParam
1: Positive ; -1: Negative
1
After restart
Indicates the moving direction of X axis. After the positive direction of each
axis is confirmed based on right-hand rule, manually move the machine
tool to see if the direction of each axis is correct. If the direction is wrong,
modify the value of this parameter.
[1E-08, 1000] mm/p
0.002
After restart
Pulse equivalent refers to the displacement or angle generated on the
corresponding axis per control pulse, i.e. the least displacement the
motion control card can deal with. For stepping system, it is the linear
value converted from angular displacement of a stepping pulse according
to transmission relation, generally corresponding to a stepping pulse.

N25

Axis direction

N26

Pulse
equivalent

N27

Check
worktable
stroke

YES: Enable; NO: Disable

YES

After restart

N28

Lower limit of
worktable
stroke

[-999999, Upper limit) mm

0

After restart

N29

Upper limit of
worktable
stroke

(Lower limit ~ 999999] mm

1500

After restart

N30

Starting speed

[0, Max. speed] mm/min

480

Immediately

N31

Max. speed

(0, Max. speed supported by hardware] mm/min

60000

Immediately

N32

Manual feed
acceleration

(0, 100000] mm/s2

2000

Immediately

N33

Manual
jerk

(0, 100000] mm/s3

10000

Immediately

N34

Frequency
dividing ratio
of X

feed

Specifies the max. allowable speed of X axis.

[-10000, 10000]
-1
After restart
The ratio between the sending pulses and feedback pulses of X axis.
Positive value stands for forward direction of axis encoder while negative
value for backward direction. Note that this value cannot be set as “0”.

2.1 YAxisParam
N35

Axis direction

1: Positive ; -1: Negative
1
After restart
Indicates the moving direction of Y axis. After the positive direction of each
axis is confirmed based on right-hand rule, manually move the machine
tool to see if the direction of each axis is correct. If the direction is wrong,
modify the value of this parameter.
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Parameter

Range

Default

Effecting

N36

Pulse
equivalent

[1E-08, 1000] mm/p

0.002

After restart

N37

Check
worktable
stroke

YES: Enable; NO: Disable

YES

After restart

N38

Lower limit of
worktable
stroke

[-999999, Upper limit) mm

0

After restart

N39

Upper limit of
worktable
stroke

(Lower limit, 999999] mm

3000

After restart

N40

Starting speed

[0, Max. speed]mm/min

480

Immediately

N41

Max. speed

(0, Max. speed supported by hardware]mm/min

60000

Immediately

N42

Manual feed
acceleration

(0, 100000] mm/s2

2000

Immediately

N43

Manual
jerk

(0, 100000] mm/s3

10000

Immediately

N44

Frequency
dividing ratio
of Y

[-10000, 10000]

-1

After restart

feed

2.2 ZAxisParam
N45

Axis direction

1: Positive ; -1: Negative

1

After restart

N46

Pulse
equivalent

[1E-08, 1000] mm/p

0.001

After restart

N47

Check
worktable
stroke

YES: Enable; NO: Disable

YES

After restart

N48

Lower limit of
worktable
stroke

[-999999, Upper limit) mm

-3000

After restart

N49

Upper limit of
worktable
stroke

(Lower limit, 999999] mm

1

After restart

N50

Starting speed

[0, Max. speed]mm/min

480

Immediately

N51

Max. speed

(0, Max. speed supported by hardware) mm/min

36000

Immediately

N52

Max.
acceleration

(0, 100000) mm/s2

2000

Immediately

N53

Max. jerk

(0, 100000) mm/s3

10000

Immediately

N54

Manual
speed

low

[0.06, Manual high speed] mm/min

1200

Immediately

N55

Manual
speed

high

[Manual low speed, min. value of max. speed of
1800
each axis] mm/min

Immediately
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Parameter

Range

Default

Effecting

N56

Stepping
speed

[0.06, max. value of all max. speed of each axis]

N57

Frequency
dividing ratio
of Z

[-10000, 10000]
-1
After restart
The ratio between the sending pulses and feedback pulses of Z axis.
Positive value stands for forward direction of axis encoder while negative
value for backward direction. Note that this value cannot be set as “0”.

N58

Encoder
feedback
tolerance

[0, 10000] mm

0.001

Immediately

N59

Speed
motion

[0.06, 36000] mm/min

15000

Immediately

N60

Lead
screw
compensation
mode

0: No compensation;
1: Backlash compensation;
2: Screw error compensation

0

After restart

N61
~
N62

Backlash X/Y

[0, 0.1] mm

0

After restart

N63

W-axis
lead
screw
compensation

0: No compensation;
1: Backlash compensation;
2: Screw error compensation

0

After restart

N64

Backlash W

[0, 0.1] mm

0

After restart

[1,1000]

300

Immediately

[0, 0064] s

0.02

Immediately

of

Z

1200

Immediately

2.4 Compensation

3.0 Track control
N65

N66

Max.
look-ahead
paths

Track smooth
time

“Track smooth time” works as post-acceleration/ deceleration. The larger
the value is, the more ambiguous the details of workpiece are, i.e. the
workpiece is smoother. But it will lead to reduction of arc radius in
machining an arc. And it will also dwarf wave peak in machining workpiece
resembling waves, as follows.

Fig. 4- 13 Track smooth time

N67

Enable
B-spline
interpolation

N68

Corner
smoothing
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1: Yes; 0: No

1

After saving

[0, 1] mm

0

Immediately

Control precision of smooth transition.

Parameter

Range

Default

Effecting

3.1 Speed/Acc
N69

G00 speed

[0.06, Max. value of max. speed of all axes]
30000
mm/min

Immediately

N70

Speed
of
simulate cut

[0, max. value of max. speed of each axis]
30000
mm/min

Immediately

[100, 100000] mm/s2

Immediately

N71

Single
axis
acceleration in
machining

N72

Single
axis
acceleration in
positioning

N73

Cornering
acceleration

N74

Default
speed

feed

N75

Gxx Jerk

N76

G00 Jerk

N77

Pause
deceleration
time

N78

Max. angle of
high-speed
connection

Single axis acceleration is used to describe the acceleration/ deceleration
capability of each feed axis, with unit “mm/s2”, depending on the physical
feature of machine, such as quality of motion part, torque, cutting load and
resistance of the feed motor. The larger its value is, the less time the
machine will spend in acceleration/ deceleration during motion process,
the higher the efficiency is. Set a smaller value at first, and repeatedly
execute typical motions for a period of time. If there is no abnormal
situation, gradually increase the value. If abnormal condition occurs,
reduce the value, with “50%~100%” insurance allowance.
[100, 100000] mm/s2

Circular speed
limit

10000

Immediately

Max. acceleration of each feed axis during the positioning of a machine
tool.
[0.001, 100000] mm/s2

5000

Immediately

The maximum acceleration when feed motion is on two adjacent axes;
recommended value is 1~2 times of single axis acceleration.
[0.06, Max. value of max. speed of all axes]
4800
mm/min

Immediately

The default speed when machining
[0.001, 9999999] mm/s3

100000

Immediately

The rate of change of single axis acceleration when cutting.
[0.001, 9999999] mm/s3

100000

Immediately

The rate of change of single axis acceleration when positioning.
[0.001, 10] s

0.5

Immediately

[0, 180] deg

90

Immediately

During machining, if the angle of two adjacent segments are larger than
“Max. angle of high-speed connection”, the speed of machining joint is “0”;
if smaller than “Max. angle of high-speed connection”, an appropriate
connection speed will be calculated according to the connection angle.
YES: Enable; NO: Disable

N79

5000

YES

Immediately

Only when “Circular speed limit” is enabled can parameters “Max.
look-ahead paths”, ”Max. speed of reference circle”, and “Min. speed of
reference circle” work.
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Parameter

Range

Default

[Min. speed of reference circle, Min. value of
5000
max. speed of all axes] mm/min

N80

Max. speed of
reference
circle

Effecting
Immediately

When a machine tool processes an arc, it will vibrate due to centripetal
force. To reduce this kind of vibration, the software limits machining speed
during machining an arc in terms of centripetal acceleration. Take default
setting as an example, the maximum line velocity of the reference circle
(Diameter: 10mm) is 1800mm/min. The formula to calculate centripetal
acceleration is

a

v2
r

; among it, r  (10 / 2)mm , v  1800mm / min . Thus

centripetal acceleration a can be calculated; when other arcs are
processed, this centripetal acceleration is the maximum allowable
centripetal acceleration. Arc speed will be limited if it is too large causing
centripetal acceleration larger than a calculated in this formula.
4.0 Others
N81

XY
actions

axes

N82

Machining
once
for
overlaps

N83

Prompt
type
when task end

N84

Enable
FrogLeaping

0; 1; 2

0

Immediately

0: None; 1: Back to fixed point; 2: Back to workpiece origin.
0: disable; 1: enable

0

After saving

Machine line, arc or dot only once if it overlaps with others.
0; 1; 2

0

Immediately

The prompt after machining ends. 0: no prompt; 1: red light on for 3s; 2:
red light always on until there is input from the mouse or keyboard.
YES: Enable; NO: Disable

YES

Immediately

Whether to enable frog leaping function, synchronizing with “FrogLeaping”
in “Layer”.
[0.01, 100] mm

10

Immediately

N85

FrogLeaping
min-length

N86

Laser power

N87

Power
Increasing
Speed

N88

Enable
lubricate

0: No; 1: Auto; 2: Manual

0

Immediately

N89

Lubricate
Length

[1, 99999] m

100

Immediately

N90

Lubricate Time

[1, 100] s

5

Immediately

N91

3
Immediately
Max Pressure [0.1, 10] V
of Proportional The maximum air pressure of proportioning valve, also the air pressure
Valve
corresponding to 100% analog.
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If the distance between start point and end pint smaller than the value of
this parameter, processing point (end point) will be jumped to directly
without frog leaping.
[0, 10] V

10

Immediately

0

Immediately

The voltage relative to 100% laser power.
[0, 1000] ms

Time (in ms) for power to increase from 0% to 100%, which can be used
to solve the problem of over-burn at the start point.

Parameter

Range
[0, 10] V

N92

Pressure
Value of
pressure in
idle

[0, 10] V

N93
N94

Reserved
Analog 1

[0, 10] V
[0, 10] V

N95

Value of
Reserved
Analog 1 in
idle

N96

Reserved
Analog 2

[0, 10] V
[0, 10] V

N97

Value of
Reserved
Analog 2 in
idle
Min
width

Adjust
mode

N100

Default
type

N101

Immediately

5

Immediately

10

Immediately

The default value of Pressure in idle.
The voltage of Reserved Analog 1 when the analog rate is 100%.
5

Immediately

10

Immediately

The default value of Reserved Analog 1 in idle.

The voltage of Reserved Analog 2 when the analog rate is 100%.

pulse

power

blow

5

Immediately

5

Immediately

The default value of Reserved Analog 2 in idle.

It specifies the allowable minimum pulse width. When the pulse width is
smaller than this value, use this value; when larger, however, use the
pulse width in duty cycle.
0: svc; 1: duty cycle

N99

10

Effecting

The voltage of Pressure when the analog rate is 100%

[0, 1000000] μs
N98

Default

1

Immediately

When SVC1 = MaxPower * Layer Power, DutyCycles = PWM DutyCycles;
When dutycycle,SVC1 = MaxPower, DutyCycles = Layer Power * PWM
DutyCycles
0: Air; 1: Nitrogen; 2: Oxygen.

0

Immediately

Enable double
Y error detect

YES: Enable; NO: Disable

YES

Immediately

N102

Y1Y2
feedback
pulse
same
direction

YES: Consistent; NO: Inconsistent

NO

Immediately

[0, 100] mm

5

Immediately

N103

Y1Y2
static
tolerance

N104

Y1Y2 dynamic
tolerance

N105

Auto
clear
workcoor

1: YES; 0: NO

N106

Laser on lead

[0, 10] s

When Y1 Y2 axes are steady, if the difference between the feedback value
and output value is bigger than this value, alarm will occur.
[0, 100] mm

5

Immediately

When Y1 Y2 axes are dynamic, if the difference between the feedback
value and output value is bigger than this value, alarm will occur.
0

Immediately

0

Immediately

Whether to clear wookcoor when start machining.
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Parameter

Range

time for scan
cutting

Default

Effecting

It can be set large when some part is left uncut in track start.
[0, 10] s

N107

Laser off lag
time for scan
cutting

0

[40, 128]

N108

The
buffer
count for scan
cutting

N109

Collide
sensitivity

N110

Enable auto
exhaust

YES: enable; NO: disable

N111

Disable
Exhaust Delay

[10, 10000] ms

N112

Start position
of exhausting

[Lower limit of Y, Upper limit of Y]

N113
~
N115

Exhausting
interval 1~3

N116

Enable
control

N117

Back distance
at breakpoint
resume

Immediately

It can be set large when some part is left uncut in track end.
95

Immediately

Modify the parameter when cutting track is dislocated. Set it large when
laser is turned on early and set it small when laser is turned on late.
[1, 0000] ms

200

Immediately

It controls the sensitivity of touching the workpiece. The larger the value is,
the less sensitivity the motion will be.

focus

NO

Immediately

1000

Immediately

Whether to enable auto exhaust function.
Delay time before disabling exhaust port when leaving out of the area.
0

Immediately

Starting position of exhausting area, in machine coordinate.
[10, 10000]

1000

Immediately

YES: enable; NO: disable

NO

Immediately

The retreat distance at breakpoint resume.

2

Immediately

The length of No. 1~3 exhausting area.

Below are parameters unique to tube cutting configuration. The parameter numbers are numbers in tube
configuration.
Parameter

Range

Default

Effecting

1.0 Manu
N04

W axis rapid
jogging speed

[0, Max speed of W-axis] r/min

16

Immediately

N05

W axis jogging
speed

[0, W-axis rapid jogging speed] r/min

5

Immediately

N06

W
stepping
speed

[0, Max speed of W-axis] r/min

5

Immediately

axis

2.3 W-axis Param
N58

Axis direction
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1: Positive ; -1: Negative
1
After restart
Indicates the moving direction of W axis. After the positive direction of
each axis is confirmed based on right-hand rule, manually move the
machine tool to see if the direction of each axis is correct. If the direction is
wrong, modify the value of this parameter.

Parameter

Range

Default

Effecting

N59

Pulse
equivalent

[1E-08, 1000] deg/p

0.01

After restart

N60

Starting speed

[0, Max. speed] r/min

0

After restart

N61

Max. speed

(0, Max. speed supported by hardware) r/min

30

Immediately

N62

Max.
acceleration

(0, 100000] deg/s2

400

After restart

N63

Max. jerk

(0, 100000] deg/s3

16000

Immediately
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4.5 Shortcut Key List
Shortcut Key

Function

Shortcut Key

Function

F1

Show shortcut keys

Ctrl+ N

New

F2

E-stop

Ctrl+ O

Open

F3

Go backward

Ctrl+ S

Save

F4

Go forward

Ctrl+ I

Import

F5

Set workpiece origin

Ctrl+ A

Select all

F6

Back to workpiece origin

Ctrl+ Shift+ A

Select invert

F7

Frame check

Shift+ A

Clear selected

F8

Simulate

Ctrl+ X

Cut

F9

Start

Ctrl+ C

Copy

F10

Pause

Ctrl+ V

Paste

F11

Stop

Delete

Delete

F12

Clear track

Ctrl+ Z

Undo

Alt+0

Ports setting

Ctrl+ Y

Redo

Alt+1

Laser

Ctrl+ G

Gallery

Alt+2

Blow

Ctrl+ T

Shape check

Alt+3

Follow-up

Ctrl+1

Instant setting

Alt+4

Burst

Ctrl+2

Layer setting

Num0

Rapid jogging speed

Ctrl+ J

Combine

Num+

Zoom in

Ctrl+ W

Set lead-in/out line

Num-

Zoom out

Ctrl+ Q

Start cut point

Num*

Fit to window

Ctrl+ P

System parameters

Num1

Manually move in W-

Ctrl+ Home

All axes go home

Num2

Manually move in Y-

Ctrl+ Backspace

Show speed/acceleration

Num3

Manually move in Z-

Shift+F9

Breakpoint resume

Num4

Manually move in X-

Ctrl+ D

Set machining direction

Num6

Manually move in X+

Ctrl+ E

Auto set machining order

Num7

Manually move in W+

Ctrl+ R

Set kerf compensation

Num8

Manually move in Y+

End

Center current point

Num9

Manually move in Z+
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4.6 Wiring Diagrams of Laser Devices
4.6.1

Wiring Diagram of IPG YLR Series Laser Device

4.6.2

Wiring Diagram of FEIBO MARS 500W Laser Device
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4.6.3

Wiring Diagram of Raycus Laser Device

4.6.4

Wiring Diagram of JK 500FL Laser Device
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4.6.5

Wiring Diagram of Maxphotonics Laser Device

4.6.6

Wiring Diagram of SPI-500W-R4 Laser Device
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1)

2)

Wiring of pin 2 and 3 of DB9 interface male head on EX30A5 terminal board need not to be overlapped, so
you do not have to make a special wire. However, wiring of pin 2 and 3 of DB9 interface female head on
EX30A4 terminal board need to be overlapped, so you need to make a special wire.
The MOD pin of EX30A5 terminal board in wiring diagrams of this section is MOD (24V).

4.7 Parameter Setting for Drivers
4.7.1

Parameter Setting for WISE Servo Driver

Para. No.

Function

Value

Description

Pr528

LED initial status

6

Monitor if the number of sent and received pulses is
correct by setting this parameter. In Bodor control
system, the correct quantity of pulse sent by control
card is detected by pulse inspection in order to
determine whether there is electrical interference.

Pr008

Command pulse
No. per motor 0
circle

When it is set to “0”, parameters Pr009 and Pr010 are
valid.

Pr009

1st numerator of
command pulse To
be
frequency
calculate
division/
d
multiplication

Pr010

Denominator of
command pulse To
be
frequency
calculate
division/multiplid
cation

Pr011

Output pulse No. 2500
per motor circle
(default)

Typical value: pulse equivalent 0.001 mm/p,
deceleration ratio 1:1, pitch 10 mm/p, sets this
parameter to 2500; pitch 5 mm/p, sets this parameter
1250.

Pr100

1st position loop 480
gain
(default)

Unit: 0.1/s. Set it according to the actual situation.

Pr101

1st velocity loop
gain

270
(default)

Unit: 0.1 Hz. Set it according to the actual situation.

Pr102

1st velocity loop
210
integrated time
(default)
constant

Unit: 0.1 ms. Set it according to the actual situation.
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Range: 0~230
Typical value: pitch 5 mm, encoder resolution 10000,
deceleration ratio 1:1, pulse equivalent 0.001 mm:
Pr009＝10000
Pr010 ＝ pitch 5 mm/ pulse equivalent 0.001 mm ＝
5000
Pr009/Pr010=10000/5000=2/1

Para. No.

Function

Value

Description

When the value of Pr008 is not “0”, it should be calculated according to the following formula:
Command pulse No.per motor circle=

Screw pitch
5mm

Pulse equivalent  Mechanical decelerationrat io 0.001mm / p

 5000

That is to say, when screw pitch is 5 mm and pulse equivalent is 0.001, the value of Pr008 is 5000.
Attached list: the relationship among parameters Pr008, Pr009 and Pr010.



Pr008

1~2

Pr009

20

Pr010

_

_

(no
influence)

(no
influence)

0

1~230

Description

As shown above, the process is undergone in terms of the
setting value of Pr008, not affected by the settings of
Pr009 and Pr010.

When the values of Pr008 and Pr009 are both set to “0”,
as shown above, the process is undergone in terms of the
setting value of Pr010.

0

1~230

1~230
When the value of Pr008 is “0”, but the value of Pr009 is
not “0”, as shown above, the process is undergone in
terms of the setting values of Pr009 and Pr010.

4.7.2

Parameter Setting for YASKAWA Σ–ⅡServo Driver

Para. No.

Function

Value

Description

Fn010

Set password
(to
prevent
arbitrary
modification
to
parameters)

0000

Set “0000”:modification
and part of auxiliary
permitted;
Set “0001”:modification
and part of auxiliary
prohibited.

to user parameters “PnXXX”
function parameters “FnXXX”

Un00C

Surveillance
mode

LXXXX
(Hexadeci

Monitor if the number of sent and received pulse is
correct by setting this parameter. In Bodor control

to user parameters “PnXXX”
function parameters “FnXXX”
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Para. No.

Function

Value
-mal
system)

Description
system, the correct quantity of pulse sent by control card
is detected by pulse inspection in order to determine
whether there is electrical interference.

Pn000

Direction
selection
0010
Control mode
selection

Bit 0: Set 0, “CCW” rotation is forward rotation (viewed
from the load end of screw ball); Set 1, the rotation
direction of the motor is reversed.
Bit 1: Set 1, position control mode (calculate pulse
instruction all the time).

Pn200

Select pulse
instruction
mode

0005

Bit 0: Set 5, select the instruction input mode as “pulse +
direction”, negative logic.
Bit3: Set 0, input differential signal into filter.

Pn50A

Selection
function

8100

Bit 1: Set 0, Servo ON /S-ON, input from the 40th pin;
Set 7, Servo ON all the time.
Bit 3: Set 8, forward rotation not used and signal input
(P-OT) prohibited.

Pn50B

Selection
function

6548

Bit 0: Set 8, reverse rotation not used and signal input
(N-OT) prohibited.

Pn50F

Selection
function

0300

Set it when servo motor with brakes.
Bit 2: Set 3, brake interlock signal “/BK” is output from
CN1-29, CN1-30 to control 24V relay for brake.

0211

Set it when servo motor with brakes.
To avoid of CN1-29 and CN1-30 being used for other
function and leading to brake ineffective, “3” is not
allowed to appear in the 4 digits.

Pn50E

Selection
function

Pn506

Servo off, time
delay of brake
Depended
when
motor
stops

Set it when motor with brakes.
Default setting is “0”, setting unit is 10 ms.

Pn201

PG
ratio

Range: 16~214. Concrete value is decided by PG divider
ratio (Bodor system).
Typical value: when pulse equivalent is 0.001, pitch 10
mm, without reducer, sets the parameter to 2500; when
pitch 5 mm, sets it to 1250.

Pn202

Electronic
gear ratio
(numerator)

To
be
calculated

Pn203

Electronic
gear
ratio
(denominator)

To
be
calculated
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divider

To
be
calculated

Pn202 = pulse No. of each encoder circle × 4 ×
mechanical deceleration ratio.
Pn203 = (screw pitch/ pulse equivalent).
Typical value: pitch 5 mm, encoder 17-bit, coaxial
connection between motor and screw, pulse equivalent
0.001 mm, Pn202＝16384; Pn203＝625.
Pitch 5 mm, encoder 17-bit, coaxial connection between
motor and screw, pulse equivalent 0.0005 mm, Pn202＝
8192; Pn203＝625.

4.7.3

Parameter Setting for YASKAWA Σ-Ⅴ/Σ-7 Servo Driver

Para. No.

Function

Value

Description

Fn010

Parameter input
prohibition
0000
setting

Set “0000”: modification to user parameters
“PnXXX” and part of auxiliary function parameters
“FnXXX” permitted. Set “0001”: modification to user
parameters “PnXXX” and part of auxiliary function
parameters “FnXXX” prohibited.

Pn000

Function
selection
switch 0

0010

Bit 0: Set 0, positive rotation at positive rotation
command; Bit 1: Set 1, position control mode (pulse
sequence command)

Pn200

Format selection
switch
of
0005
position control
command

Bit 0: Set 5, select the instruction mode as “pulse +
direction”, negative logic.

Pn50A

Input
signal
selection 1

8100

Bit 1: Set 0, Servo ON /S-ON, input from the 40th pin;
Set 7, Servo ON all the time. Bit 3: Set 8, positive
rotation not used and signal input (P-OT) prohibited.

Pn50B

Input
signal
selection 2

6548

Bit 0: Set 8, negative rotation not used and signal
input (N-OT) prohibited.

0300

Set it when servo motor with brakes.
Bit 2: Set 3, brake interlock signal “/BK” is output
from CN1-29, CN1-30 to control 24V relay used for
brake.

0211

Set it when servo motor with brakes.
To avoid of CN1-29 and CN1-30 being used for other
function and leading to brake ineffective, 3 is not
allowed to appear in the 4 digits.

Pn50F

basic

Output
signal
selection 2

Pn50E

Output
signal
selection 1

Pn506

Brake
instructionDepended
servo OFF time
delay

Set it when motor with brakes
Default setting is “0”, setting unit is ms.
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Para. No.

Function

Value

Description
Pn20E

Electronic gear
To
be
ratio
calculated
(numerator)

Pn20E

Pn210

=

Encoder resolution  Pulse equiv  Decele ration ratio

Screw pitch

For example, screw pitch 5 mm, 20-bit encoder,
coupling direct drag, pulse equivalent 0.001 mm,
Pn20E
Pn210



220  0.001 1048576 131072


5
5000
625

When screw pitch is 10 mm,

1048576 65536

Pn210
10000
625
For a rotary axis with
deceleration ratio as 60,
Pn20E

Electronic gear
Need
ratio
Calculation
(denominator)

Pn210

Pn20E
Pn210

Pulse
allocated
encoder

Pn212

4.7.4

No.
by

To
be
calculated





13-bit

encoder

and

213  0.001 60 8192 512


360
6000 375

Range: 16~230. Concrete value is decided by PG
divider ratio.
When pulse equivalent is 0.001, pitch 10 mm,
without reducer, sets this parameter to 2500; when
pitch 5 mm, sets it to 1250.

Parameter Setting for PANASONIC MINAS A4 Servo
Driver

Para. No.

Function

Value

Description

12

Monitor if the number of sent and received pulse is
correct by setting this parameter. In Bodor control
system, the correct quantity of pulse sent by control
card is detected by pulse inspection in order to
determine whether there is electrical interference.

0

0: position mode
1: velocity mode
2: torque mode

Pr01

LED initial status

Pr02

Select
mode

Pr40

Selection
of
command pulse 1
input

1: input by differential exclusive circuit

Pr42

Select command
pulse
input
mode

Set command pulse input mode: pulse + direction,
negative logic
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control

3

Para. No.

Function

Value

Pr44

Numerator
of
feedback pulse To
be
frequency
calculated
multiplication

Pr48

1st numerator of
command pulse
frequency
multiplication

To
be
calculated
Range:
1~10000

Pr4B

Denominator of
command pulse
frequency
multiplication

To
be
calculated
Range:
1~10000

4.7.5

Description
Range: 1~32762. Concrete value is decided by PG
divider ratio.
When pulse equivalent is 0.001, pitch 10 mm,
without reducer, sets this parameter to 2500; when
pitch 5 mm, sets it to 1250.
Typical value: pitch 5 mm, encoder resolution 10000,
shaft coupling direct drag, pulse equivalent 0.001
mm:
Pr48＝10000
Pr4B ＝ pitch 5 mm / pulse equivalent 0.001 mm ＝
5000
Pr48/Pr4B=10000/5000=2/1

Parameter Setting for PANASONIC MINAS A5 Servo
Driver

Para. No.

Function

Pr5.28

LED initial status

Pr0.01

Select
mode

control

Value

Description

6

Monitor if the number of sent and received pulse is
correct by setting this parameter. In Bodor control
system, the correct quantity of pulse sent by control
card is detected by pulse inspection in order to
determine whether there is electrical interference.

0

0: position mode
1: velocity mode
2: torque mode

Pr0.05

Selection
of
command pulse XX
input

0: Photo-coupler input (PULS1, PULS2, SIGN1,
SIGN2)
1: Exclusive input for line driver (PULSH1, PULSH2,
SIGNH1, SIGNH2)
Note: generally, “1” is selected for this parameter.

Pr0.07

Command pulse
input
mode 3
setup

Set command pulse input mode: pulse + direction,
negative logic.

Pr0.08

Command pulse
counts per one 0
motor revolution

When it is set as “0”, parameters Pr0.09 and Pr0.10
are valid.
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Para. No.

Function

Value

Pr0.09

1st numerator of
command pulse
frequency
multiplication

To
be
calculated
Range:
0~230

Pr0.10

Denominator of
command pulse
frequency
multiplication

To
be
calculated
Range:
0~230

Pr0.11

Output pulse No.
per one motor 2500
revolution

Description
Typical value: pitch 5 mm, encoder resolution 10000,
shaft coupling direct drag, pulse equivalent 0.001
mm:
Pr0.09＝10000
Pr0.10 ＝ pitch 5 mm/ pulse equivalent 0.001 mm ＝
5000
Pr0.09/Pr0.10=10000/5000=2/1
Range: 1~262144. Concrete value is decided by PG
divider ratio.
When pulse equivalent is 0.001, pitch 10 mm,
without reducer, sets this parameter to 2500; when
pitch 5mm, sets it to 1250.

When the value of Pr0.08 is not “0”, it can be calculated in terms of the following formula:
Command pulse No.per motor circle=

Screw pitch
5mm

Pulse equivalent  Mechanical decelerationrat io 0.001mm / p

 5000

When screw pitch is 5 mm and pulse equivalent 0.001 mm/p, the value of Pr0.08 is “5000”.
Attached List: the relationship among parameters Pr0.08, Pr0.09 and Pr0.10.



Pr0.08

1~220

Pr0.09

Pr0.10

—
(no influence)

—
(no influence)

0

1~230

1~230

1~230

Description

The process shown above is undergone in terms of
the setting value of Pr0.08, not affected by the
settings of Pr0.09 and Pr0.10.

When the values of Pr0.08 and Pr0.09 are both set
as “0”, as shown above, the process is undergone in
terms of the setting value of Pr0.10.

0
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When the value of Pr0.08 is “0”, but the value of
Pr0.09 is not “0”, as shown above, the process is
underdone in terms of the setting values of Pr0.09
and Pr0.10.

4.7.6

Parameter Setting for FUJI FALDIC-β Servo Driver

Para.

Name

No.

Description

To
be
calculated
1~32767

Command pulse numerator and denominator are
equal to those of the electronic gear ratio.
α/ β=encoder resolution× pulse equivalent×
mechanical deceleration ratio / screw pitch.
Typical value: encoder resolution 65536, pitch 5 mm,
pulse equivalent 0.001, mechanical deceleration ratio
1,
α / β=65536×0.001 / 5=8192 / 625,
So α=8192, β=625.

01

Command
numerator α

02

To
be
Command
pulse
calculated
denominator β
1~32767

03

Pulse
form

04

Direction of rotation
0 or 1
switch

Set 0: Positive direction: Forward rotation (CCW)
Set1: Positive direction: Reverse rotation (CW)

10

CONT1
distribution

1

CONT1 is distributed as RUN (i.e. SON); if not
distributed, CONT1 will be auto ON if there is no
alarming when powered.

2

CONT2 is distributed as RST (i.e. servo alarming
clearance CLR).
When 12, 13, 14 are 0, that is CONT3, CONT4 and
CONT5 can’t be distributed as OT over-travel or EMG
(external emergency stop).

1

Set 1, OUT1 is distributed as a-contact point of
alarming output;
Set 2, OUT1 is distributed as b-contact point of
alarming detection.

11

pulse

Value

string

CONT2
distribution

input

signal

signal

signal

0

Set the input mode of pulse string as: instruction +
symbol, that is ‘pulse + direction’.

15

OUT1
distribution

27

Parameter
write-protection

0 or 1

Set 0, write-enable.
Set 1, write-protected.

74

CONT always ON 1

1

Initial value: 0. when set “1”, servo is activated (RUN).
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4.7.7

Parameter Setting for DELTA ASDA-A Servo Driver

Para. No.

Function

P0-02

Driver
display

P1-00

External
pulse
input type

P1-01

Control
setup

Format &
Range

status

mode

ZYX

ZYX1X0

Value

02

Monitor if the number of sent and
received pulse is correct by setting this
parameter. In Bodor control system, the
correct quantity of pulse sent by control
card is detected by pulse inspection to
determine
if
there
is
electrical
interference.

002

X=2: pulse + direction;
Z=0: positive logic

0000

Z=0: during control mode switching, DIO
is maintaining the set value. Since
switching control mode is not used, Z=0
Y=0: forward rotation (CCW) (in terms of
load);
Y=1: the rotation direction is reversed.
X1X0=00: position control mode
Y=0: when there is no servo enabled,
motor dynamic brake occurs; Y=1: motor
is free.
X=0: motor stops instantly, X=1: motor
stops with deceleration.

P1-32

Motor stop mode
YX
selection

00

P1-44

Electronic Gear
Ratio
1~32767
(Numerator)(N1)

To
be
calculated

P1-45

Electronic Gear
Ratio
1~32767
(Denominator)
(M)

To
be
calculated

P2-10

Digital Input Pin
X2X1X0
DI1
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Description

101

N1/M= encoder pulses × 4× pulse
equivalent× mechanical deceleration
ratio/ pitch
Representative
value:
encoder
pulses=2500,
pitch=5
mm,
pulse
equivalent=0.001, deceleration ratio=1,
calculation as follows.
N1/M= 2500×4×0.001/5 = 2 / 1, N1=2,
M=1;
When the multi-electronic gear ratio is
not used, P2-60~P2-62 are not required.
X1X0=01: digital input (DI1=SON)
corresponds to 9th pin of CN1.
X2 = 1: set DI1 input as NO (normally
open) a-contact point.

Para. No.

Function

Format &

Value

Range

Description
Default factory setting of DI6 and DI7 are
NC (normally closed) limit signal input
pins; driver can’t run without being
connected to pin 32 and pin 31 of CN1.
X2=1: set DI6 and DI7 inputs as NO
(normally open) a-contact points;
X1X0=00, limit signal input of the driver
is not used.

P2-15

Digital Input pin
X2X1X0
DI6

100

P2-16

Digital Input Pin
X2X1X0
DI7

100

P2-17

Function setting
for digital input X2X1X0
pin DI8

100

External EMG stop input is not used.

108

DO4 corresponds to pin 1 & pin 26, used
as clamping-position brake signal of
Z-axis;
X2=1: set DO4 output as NO (normally
open) a-contact point; X2=0: set DO4
output as NC (normally closed) b-contact
point;
X1X0=08: set pin 1 and pin 26 as BK+
and BK- respectively.

007

DO5 corresponds to pin 28 & pin 27,
used as servo alarm signal.
X2=0: set DO5 output as NC (normally
closed) b-contact point.
X1X0=07: set pin 28 and pin 27 as
ALRM+ and ALRM- respectively.

0

0: Servo ON must be triggered by
numerical input signal.
1: when servo is powered, if there is no
alarm signal, servo will be automatically
on. Set 1 when there is no SON signal
wire.

P2-21

P2-22

P2-51

Function setting
for digital output X2X1X0
pin DO4

Function setting
for digital output X2X1X0
pin DO5

Servo ON (SON)
setup
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4.7.8

Parameter Setting for DELTA ASDA-A2 Servo Driver

Para. No.

Function

P0-02

Driver
display

P1-00

External
pulse
train input type

Format &
Range

status

ZYX

02

102

X=2: pulse + direction;
Z=0: positive logic

0000

Z=0: during control mode switching, DIO
is maintaining the set value. Since
switching control mode is not used, Z=0;
Y=0: positive rotation (CCW) (from the
view of load);
Y=1: negative rotation (CCW)
X1X0=00: position control mode

Set control mode

P1-44

Electronic Gear
Ratio
1~32767
( Numerator)
(N1)

To
be
calculated

Electronic Gear
Ratio
1~32767
(Denominator)
(M)

To
be
calculated

P1-46

P2-10

Detector output
pulse No. setting

20~
320000

Digital Input Pin
X2X1X0
1 (DI1)

「126」Appendix

Description
Monitor if the number of sent and
received pulse is correct by setting this
parameter. In Bodor control system, the
correct quantity of pulse sent by control
card is detected by pulse inspection in
order to determine whether there is
electrical interference.

P1-01

P1-45

ZYX1X0

Value

P1-44 =
P1-45
Encoder resolution创Pulse equiv Decelerat. ratio
Pitch

Assuming
encoder
resolution
is
1280000, pitch 5 mm, pulse equivalent
0.001, and non-cascade connection,
then:
P1-44 1280000*0.001 256
=
=
P1-45
5
1

When the multi-electronic gear ratio is
not used, P2-60~P2-62 are not required.

To
be
calculated

Concrete value is decided by PG divider
ratio.
Assuming encoder resolution is 0.001,
pitch 10 mm, without reducer, then set
this parameter to 10000; when pitch is
5mm, set it to 5000.

101

X1X0=01: digital input (DI1 = SON)
corresponds to 9th pin of CN1.
X2=1: set DI1 input as NO (normally
open) a-contact point.

Para. No.

Function

Format &

Value

Range

Description

P2-15

Function setting
for digital input X2X1X0
pin DI6

100

P2-16

Function setting
for digital input X2X1X0
pin DI7

100

P2-17

Function setting
for digital input X2X1X0
pin DI8

100

External EMG stop input is not used.

108

DO4 corresponds to pin 1 & pin 26, used
as clamping-position brake signal of
Z-axis;
X2=1: set DO4 output as NO (normally
open) a-contact point; X2=0: set DO4
output as NC (normally closed) b-contact
point;
X1X0=08: set pin 1 and pin 26 as BK+
and BK- respectively.

007

DO5 corresponds to pin 28 & pin 27,
used as servo alarm signal.
X2=0: set DO5 output as NC b-contact
point.
X1X0=07: set pin 28 and pin 27 as
ALRM+ and ALRM- respectively.

P2-21

P2-22

4.7.9
Para.
No.

Function setting
for digital output X2X1X0
pin DO4

Function setting
for digital output X2X1X0
pin DO5

Default factory setting of DI6 and DI7 is
NC (normally closed) limit signal input;
driver can’t run without being connected
to pin 32 and pin 31 of CN1.
X2=1: set DI6 and DI7 input as NO
a-contact points.
X1X0=00, limit input of driver is not used.

Parameter Setting for DELTA ASDA-B Servo Driver
Function

P0-02

Driver
display

P1-00

External
pulse
train input type

Format

Value

& Range

status

ZYX

Description

02

Monitor if the number of sent and received
pulse is correct by setting this parameter. In
Bodor control system, the correct quantity
of pulse sent by control card is detected by
pulse inspection in order to determine
whether there is electrical interference.

002

X=2: pulse + direction;
Z=0: positive logic
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Para.
No.

P1-01

Function

Set control mode

Format

Value

& Range

YX1X0

000

Y=0: forward rotation (CCW) (from the view
of load)
Y=1: the rotation direction is reversed.
X1X0=00: position control mode

00

Y=0: when there is no servo enabled,
motor dynamic brake occurs; Y=1: motor is
free.
X=0: motor stops instantly;
X=1: motor stops with deceleration.

P1-32

Motor stop mode

P1-44

Electronic Gear
Ratio
1~32767
(Numerator)
(N1)

To
be
calculated

P1-45

Electronic Gear
Ratio
1~32767
(Denominator)
(M)

To
be
calculated

P2-10

Digital Input Pin
X2X1X0
1 (DI1)

P2-15

YX

Function setting
for digital input X2X1X0
pin DI6

P2-18

Function setting
for digital output X2X1X0
pin DO1

P2-20

Function setting
for digital output X2X1X0
pin DO3
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Description

N1/M= mechanical deceleration ratio × 4 ×
encoder pulses × pulse equivalent / pitch.
Representative
value:
encoder
pulses=2500, pitch =5 mm, pulse
equivalent=0.001 mm/p, deceleration ratio
= 1, calculation as follows.
N1 / M = 2500×4×0.001/5 = 2/1, N1=2,
M=1;
When the multi-electronic gear ratio is not
used, P2-60~P2-62 are not required.

101

X1X0=01: digital input (DI1 = SON)
corresponds to 17th pin of CN1.
X2=1: set DI1 input as NO (normally open)
a-contact point.

100

Default factory setting of DI6 is NC
(normally closed) limit signal input; driver
can’t run without being connected to pin 32
and pin 31 of CN1.
X2=1: set DI6 input as NO a-contact point.
X1X0=00, limit input of driver is not used.

108

DO1 corresponds to the 16th pin, as
clamping-position brake signal of Z-axis;
X2=1: set DO1 output as NO a-contact
point;
X2=0: set DO1 output as NC b-contact
point;
X1X0=08: set the 16th pin as BK+.

007

DO3 corresponds to pin 1, used as servo
alarm signal.
X2=0: set DO3 output as NC b-contact
point; X1X0=07: set pin 1 as ALRM+.

4.7.10 Parameter Setting for DELTA ASDA-B2 Servo Driver
Para. No.

Function

P0-02

Driver
display

P1-00

External
pulse
train input type

Format &
Range

status

ZYX

02

102

X=2: pulse + direction;
Z=1: positive logic

0000

Z=0: during control mode switching, DIO
is maintaining the set value. Since
switching control mode is not used, Z=0;
Y=0: forward rotation (CCW) (from the
view of load);
Y=1: the rotation direction is reversed.
X1X0=00: position control mode

Set control mode

P1-44

Electronic Gear
Ratio
1~32767
(Numerator)
(N1)

To
be
calculated

P1-45

Electronic Gear
Ratio
1~32767
(Denominator)
(M)

To
be
calculated

P2-10

Detector output
pulse No. setting

20~40000

Digital Input Pin
X2X1X0
DI1

Description
Monitor if the number of sent and
received pulse is correct by setting this
parameter. In Bodor control system, the
correct quantity of pulse sent by control
card is detected by pulse inspection in
order to determine whether there is
electrical interference.

P1-01

P1-46

ZYX1X0

Value

N1/M= mechanical deceleration ratio × 4
× encoder pulses × pulse equivalent /
pitch.
Representative
value:
encoder
pulses=40000, pitch =5 mm, pulse
equivalent=0.001, deceleration ratio = 1,
calculation as follows.
N1 / M = 40000×4×0.001/5 = 32/1,
N1=32, M=1;
When the multi-electronic gear ratio is
not used, P2-60~P2-62 are not required.

To
be
calculated

It sets detector output pulse number,
whose concrete value is decided by PG
divide ratio.
When pulse equivalent = 0.001 mm/p,
pitch=10 mm, without reducer, sets this
parameter to 10000; when pitch=5 mm,
sets it to 5000.

101

X1X0=01: digital input (DI1 = SON)
corresponds to 9th pin of CN1.
X2=1: set DI1 input as NO (normally
open) a-contact point.
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Para. No.

Function

Format &
Range

Value

Description

P2-15

Function setting
for digital input X2X1X0
pin DI6

000

P2-16

Function setting
for digital input X2X1X0
pin DI7

000

P2-17

Function setting
for digital input X2X1X0
pin DI8

000

External EMG stop input is not used.

108

DO1 corresponds to pin 6 & pin 7, used
as clamping-position brake signal of
Z-axis;
X2=1: set DO1 output as NO (normally
open) a-contact point; X2=0: set DO1
output as NC (normally closed) b-contact
point;
X1X0=08: set pin 6 and pin 7 as BK- and
BK+ respectively.

007

DO5 corresponds to pin 28 & pin 27,
used as servo alarm signal.
X2=0: set DO5 output as NC b-contact
point.
X1X0=07: set pin 28 and pin 27 as
ALRM+ and ALRM- respectively.

P2-18

P2-22

Function setting
for digital output X2X1X0
pin DO1

Function setting
for digital output X2X1X0
pin DO5

「130」Appendix

Default factory setting of DI6 and DI7 is
NC (normally closed) limit signal input;
driver can’t run without being connected
to pin 32 and pin 31 of CN1.
X2=0: set DI6 and DI7 inputs as NC
b-contact point.
X1X0=00, limit input of driver is not used.

4.8 Wiring Diagrams of Drivers
4.8.1

Wiring Diagrams of WISE Servo Driver
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4.8.2

Wiring Diagrams of YASKAWA Σ-Ⅱ/Σ-Ⅴ/Σ-7 Servo Driver
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4.8.3

Wiring Diagram of PANASONIC AC Servo Driver

4.8.4

Wiring Diagram of FUJI Servo Driver
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4.8.5

Wiring Diagrams of DELTA Servo Driver

DELTA ASDA-A, ASDA-A2, ASDA-AB share the same wire. Among them, ASDA-A2 and ASDA-AB have
the same wiring pin while ASDA-A has the contrary pulse pin, with PULSE 41, /PULSE 43. For detailed
parameter setting, refer to section 4.7.6 and section 4.7.8
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4.9 Software License Agreement
Important—Read Carefully before Using This Product:
The term “Software Product” includes all copies of the licensed software and its documentation. This
license agreement is a legal agreement between You (either an individual, a legal entity or any affiliated
companies or other entities) and Jinan Bodor CNC Machine Co.,Ltd. (hereinafter referred to as Bodor
Company). By installing, copying, or otherwise using the Software Product, you agree to be bound by
the terms and conditions of this license. Unless otherwise stated in this agreement, you shall not use,
copy, revise, rent, or transfer the Software product or any part of the Software Product for any other
purposes.
Description of Further Rights and Restrictions:
1.

You may install for use one copy of the Software Product on a single machine;

2.

You may make a copy of the Software Product for archive or backup purposes and the copy is to be
used on this machine only;

3.

You may transfer the Software Product and the license agreement to a third party, provided that the
third party accepts the terms and conditions stated in this agreement, with prior express permission
from Bodor Company;

4.

When transfer confirmed, you shall transfer all the copies of the original documents and the
supplementary documents to the third party or destroy all the copies un-transferred.

5.

You can use the Software Product on a network server or intranet server only if it is stipulated in
explicit terms that you are allowed to use the Software Product on a network server or intranet
server, or you have purchased license for each node and terminal using the Software Product;

6.

You may NOT sublicense, assign or transfer the license agreement;

7.

You may NOT or direct any third party to reverse engineer, decompile or disassemble the Software
Product;

8.

You may NOT copy or transfer the Software Product or any part of the Software Product unless
otherwise expressly stated in this agreement;

9.

The license agreement shall be terminated automatically upon you transfer the Software Product or
copies of all or part of the Software Product to a third party.

Intellectual Property Rights Notice:
The Software Product and all intellectual property rights therein (including but not limited to any all
copyrights, patents, trademarks, and publicity rights) are owned by Bodor Company. The Software
Product is protected for Bodor Company on the basis of copyright law and international treaty provisions
as well as on the basis of other laws and agreements regarding intellectual property. You are not allowed
to remove the copyright statement made in the Software Product, and guarantee that you shall copy the
copyright statement in all copies of the Software Product or of any part of the Software Product. You are
obliged to stop any form of illegal copying of the Software Product and accompanying materials.
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After-sales Guarantee:
Bodor Company guarantees that for 90 days from the date of shipment the software carrier will be free
from defects in materials and workmanship. When such a defect has been confirmed, our only
responsibility is to replace the software carrier. This remedy is your exclusive remedy. This after-sales
guarantee is invalid for any carrier defect caused by accidents, abuses or maloperation. The replaced
software carrier enjoys the remaining guarantee time of the original software carrier or of a 30-day
guarantee time, whichever is longer.
Except as the after-sales guarantee made above, the Software Product does not enjoy any other form of
after-sale guarantee.
Limitation of Liability:
The above guarantee, whether made explicitly or by implication, constitutes the entire contents of the
guarantee, including guarantee for the commerciality and applicability of special application aim.
Whether you follow other terms in this agreement or not, Bodor Company, as well as its agents and sales
staff, will not be responsible for any profits loss, availability loss, business break-off or any forms of
indirect, special, accidental or inevitable damage or claim made by any third party, generated from the
using of the Software Product, even if Bodor Company has been informed of the possible occurrence of
such events in advance.
Termination:
This license may be terminated by Bodor Company at any time once you violate any terms or conditions
made in this agreement. Once the license is terminated, you are obliged to destroy all the copies of the
Software Product or return them to Bodor Company.
Applicable Law:
Copyright Law, Regulations for the Protection of Computer Software, Patent Law and other relevant
laws and regulations.
Now, we affirm that you have already read through this agreement and understood it thoroughly and
agreed to comply with all of the terms and conditions of this agreement strictly.
Jinan Bodor CNC Machine Co.,Ltd.
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